Location added to model disappeared after adding equipment

Hi all, Just getting started with openHabian on a new Raspberry PI 4 B that I got for Christmas.

  • Platform information:
    • Hardware: Raspberry PI 4 B
    • OS: openHabian
    • Java Runtime Environment: unsure, whatever came with openHabian image
    • openHAB version: 3.2.0

Am at the stage of setting up semantic model and adding my newly discovered equipment to the model. This worked fine for two locations but when I selected the equipment to add to a third location, the location disappeared from the model. If I try adding the location into the model again, it says it already exists (see image below). But it’s nowhere to be seen and I can’t select it.

Do I restart the Raspberry PI, restart the service, delete the model and start again?


First try reloading the page, clearing the cache of the browser if a simple reload doesn’t work. Then try restarting OH and reload the page again. You don’t need to delete the model itself.

Thanks for the tips

I’ve now done

  • normal refresh (F5)
  • hard refresh (ctrl-F5)
  • empty cache and hard refresh (hold refresh button with Dev tools open)
  • restart openHabian
  • restart Raspberry PI

None of these has returned the location and I still can’t re-add the location that is no longer shown.


Use the API Doc Explorer (under developer tools) and query for that Item. Does it exist in Items? Is there a Link to that Item? Groups should not be linked to Channels so that could cause some issues.

I have the same issue, went through the same reload steps as above before even finding this thread, and the location has child locations that don’t show either. When I execute a search for the uppermost missing location by name using the API explorer I get a stack overflow (below). Other items return results as I would expect, including the child locations. Is there any kind of database repair utility that can be tried?

Or am I stuck starting over? If so, is there a way I haven’t discovered to export the current configuration that can be imported later?

“{“error”:{“message”:“Stack overflow during pattern compilation near index 0\n[\\w-]\n^",“http-code”:500,“exception”:{“class”:“java.util.regex.PatternSyntaxException”,“message”:"Stack overflow during pattern compilation near index 0\n[\\w-]\n^”,“localized-message”:“Stack overflow during pattern compilation near index 0\n[\\w-]*\n^”}}}”

What’s the error that was printed to openhab.log. That JSON pretty much only tells us that an error occurred. The logs will have a lot more information.

What version of OH?

OH3.2.0. It was an “in situ” upgrade from OH2. Don’t yet know how to get to the logs in this version, but I got “froggy” and decided to try to delete that uppermost location using the API explorer in the developer tools, and it worked! (didn’t really have that much to lose if it got even more corrupted…) The child locations that were missing re-appeared, too. Pressing on. The things slowing me down now are 1) it’s frequently “sluggish” actually activating a switch, 2) trying to figure out how to use the Astro Sun Data to trigger a script, 3) I’ve got a new (as in brand new this year–didn’t know that when I bought it) device that it doesn’t recognize so I need to

and so figure out that entire process.

Thanks for the response.

It’s the same logs in mostly the same place. Just replace openhab2 with openhab in your paths. If you are using openHABian then Frontail should have been updated automatically with the new paths.

It’s the same as it’s always worked, conceptually. Create the Thing. Create a Rule. Use a Thing Event to trigger the rule and choose the Astro Channel desired.

I can’t help with 1 with the given information (probably belongs in a separate thread anyway.