Log viewer not working after restoring configuration

I had OH3 running successfully but I lost ssh access. Unfortunately, I corrupted the SD card shutting down the rPi. So I started from scratch and installed the latest openhabian image and restored a configuration I saved about 6 weeks ago. Definitely saved me from redoing it all. However, the log viewer is not functionality. I get the following errors when I check the status on openhab service

openhabian@casajuarez:~ $ sudo /bin/systemctl status openhab.service
● openhab.service - openHAB instance, reachable at http://casajuarez:8080
   Loaded: loaded (/lib/systemd/system/openhab.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/openhab.service.d
   Active: active (running) since Tue 2021-06-01 13:14:18 PDT; 3h 2min ago
     Docs: https://www.openhab.org/docs/
 Main PID: 654 (java)
    Tasks: 200 (limit: 2181)
   CGroup: /system.slice/openhab.service
           └─654 /usr/bin/java -XX:-UsePerfData -Dopenhab.home=/usr/share/openhab -Dopenhab.conf=/etc/openhab -Dopenhab.runtime=/usr/share/openhab/runtime -Dopenhab.userdata=/var/lib/openhab -Dopenhab.lo

Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:891)
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:605)
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:112)
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:534)
Warning: The unit file, source configuration file or drop-ins of openhab.service changed on disk. Run 'systemctl daemon-reload' to reload units.
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:888)
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:824)
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
Jun 01 13:16:30 casajuarez karaf[654]:         at java.xml/com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:246)
Jun 01 13:16:30 casajuarez karaf[654]:         ... 16 more
Jun 01 13:16:30 casajuarez karaf[654]: org.ops4j.pax.logging.pax-logging-api [log4j2] ERROR : No logging configuration Ignored FQCN: org.apache.logging.log4j.spi.AbstractLogger
lines 1-23/23 (END)

I looked at the similar but I haven’t found one that could help. Hopefully someone can point me where to start troubleshooting.


Here’s an update. Once again, I got bitten by a corrupted log4j2.xml file. In an earlier post, the GUI was not starting up and once that was fixed, the log file did not start. So I went back to inspect log4j2.xml file and it seemed to be garbled; like a different character set. I went back to another OH3 installation and verify I could read the file so I copied it over again. I then stopped OH3, cleared the cache and reset permissions for OH directories. Restarted and I’m back. Leaving this post in case anyone encounters a similar issue.

Hello Tony,
I corrupted my SD-card after a failed upgrade of my system. I doesn’t start anymore.
After a fresh installation and a restored configuration I’m having exact the same issue.
Before I noticed the log is not working Mosquitto had a problem too to start. I solved this with:

  sudo mkdir -p /var/log/mosquitto /opt/zram/log.bind/mosquitto
  sudo chown mosquitto /var/log/mosquitto /opt/zram/log.bind/mosquitto

Maybe this is related…
Can you explain a bit more what you did to solve the Log viewer?

Kind Regards, Hans

@SuysH, I was on vacation so not checking messages. Are you still having issues?

@tdlr Thanks for your reply.
The problem is solved by running the openhabian-config and install frontail again (or it was not installed by default on my fresh setup)
Regards, Hans