Long Boot Time

Hello,

First of all i would like to Say Hello to every body here :slight_smile:

Recently i did a fresh install of OpenHABian to my new Raspberry pi 4 B+ with argon one and samsung evo m.2 SSD.
I’ve noticed that boot time is quite long systemctl analyze is stating that startup took nearly 2 minutes.

The problem is with:
“A start job is running for /dev/sda3 (1m30s)” O_o

So i tried to make a fresh install on USB 3.0 stick and from stick everything was perfect…
But this isn’t a solution because i want to use an SSD :confused:

Any clue why from 250 Gb samsung SSD (usb atttached with UASP) its not so fast ?

It’s not slow but probably trying to mount the partition /dev/sda3 but that is probably missing on your SSD.
I don’t know what features you have configured that might be responsible for this behavior and what you did to move to SSD so cannot help you there (and frankly don’t want to) .
SSDs are not supported, this being one of the reasons.
They mean a helluva lot more possible combinations that would require to be tested with every other piece of openHABian, and they’re not needed anyway so that’s why. So you are on your own there.

So basically i just burned official ooenhabian image by etcher to the SSD, in the same way i did with thumb stick.
And that is a clean install without any additional software.

The software is working based on the assumption that it’s installed to an SD card, there are multiple references in the code.
So that was not a clever move. You should follow the installation instructions.

Ok, so to claryfi…

I should first Burn image to SD as usual and than use ooenhabian-config to RAW copy SD (option 54) to external drive or use Sync SD (option 55)?
Witch one of thoose is better?

Go read the docs please.
We don’t write them just to have users ask us about what’s written in there.

@Shalvan_StatX hi

I just installed an argon one m2 also.
could you kindly advise how you implemented finally?

did it work ok? are you satisfied?
Did you upgrade to OH3 by any chance? and more importantly of all :slight_smile: have you installed the script for the fan and does it work!

thanks in advance for your insight

Alex

Hi Alex,

Sorry for late reply, Yes finally the argon case is working perfectly and the fan script (console one that i’m using) also works great, i’ve just changed temp settings to keep it as cool as possible so the fan is running at arround 70-80% it can be little anoying because the fan isnt so quiet.

As for the OH installation i did clean install of OH3.

Wysłane z aplikacji Poczta dla systemu Windows

Od: Alexandros Karageorgis via openHAB Community
Wysłano: czwartek, 7 października 2021 18:43
Do: shalvan25@gmail.com
Temat: [openHAB] [Setup, Configuration and Use/Beginners] Long Boot Time







alexkarageorgis Alexandros Karageorgis
October 7

@Shalvan_StatX hi

I just installed an argon one m2 also.
could you kindly advise how you implemented finally?

did it work ok? are you satisfied?
Did you upgrade to OH3 by any chance? and more importantly of all :slight_smile:have you installed the script for the fan and does it work!

thanks in advance for your insight

Alex

Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

hey @Shalvan_StatX you got me very excited about the possibility of having a quiet kitchen again!

can you explain (as if to a child :)) how you installed the script to make it work in oh3 (Openhabian right?) ? I followed the instructions and installed via putty (from here - Argon ONE Guide – Wagner’s TechTalk)

did this pretty much

  • Connect your Pi to the internet (WiFi or Ethernet).
  • Open a shell-terminal. (putty openhabian user)
  • Copy & paste the following command and press ENTER (yes, don’t forget the ” | bash” at the end or it won’t work properly):

curl https://download.argon40.com/argon1.sh | bash

  • Type exit and press ENTER.
  • The scripts will become active after installation. Therefore, rebooting isn’t necessary.

But the fan stays on all the time and I dont know enough to make it work - the config option works to change the setting but it doesnt actually work / change anything.

I should add i didnt use the console but rather openhabian to try the above

Help :slight_smile:

I had the same problem as is described on top of this topic, with exactly the same screen output. It occured after I removed the SD mirroring (openhabian-config menu 53 Remove SD mirroring).

The file /etc/systemd/system/storage.mount still contained a section which referred to /dev/sda3:

[Mount]
What=/dev/sda3
Where=/storage
Type=ext4

After removing this section, the boot time was normal again.

1 Like

Small correction: the proper way to do it is removing the storage.mount file. Otherwise some error messages remain in the boot log.

I tested it again today:

  • Remove SD mirroring in openhabian-config
  • Shutdown the system
  • Remove the attached USB reader with the backup SD card
  • Reboot

The booting process pauses for 1min 30s while it tries to find /dev/sda3.
Afterwards, the file /var/log/daemon.log contains these lines:

Jan  8 09:31:12 ddfpi4 systemd[1]: dev-sda3.device: Job dev-sda3.device/start timed out.
Jan  8 09:31:12 ddfpi4 systemd[1]: Timed out waiting for device /dev/sda3.
Jan  8 09:31:12 ddfpi4 systemd[1]: Dependency failed for /storage mount.
Jan  8 09:31:12 ddfpi4 systemd[1]: storage.mount: Job storage.mount/start failed with result 'dependency'.
Jan  8 09:31:12 ddfpi4 systemd[1]: dev-sda3.device: Job dev-sda3.device/start failed with result 'timeout'.

I am not an expert, but I guess the file /opt/openhabian/functions/backup.bash should contain an extra line in the “remove” section of setup_mirror_SD():

rm /etc/systemd/system/storage.mount

My configuration:

  • RPi 3B+
  • Raspbian Bullseye
  • OH 3.2.0
  • Openhabian Main Branch

Thing is, you may want to disable mirroring but still use /storage e.g. because your Amanda backups are located there.
That’s unrelated to mirroring in the first place so it would be wrong to remove on mirror disabling.
Also, you can choose a different dirname and that also results in a different name for the systemd file.

It is a minor issue as few people will stop using SD mirroring once they have installed it successfully. And reboots ideally don’t occur very often.