Looking for help troubleshooting why I can't get my installation to go online after a restoration


A few weeks ago I restored my Pi because of a corrupted SD card. Following that my setup has been unable to connect to myopenhab. I have checked that my SECRET and UUID are correct. My Pi is connected to the internet. I was thinking it might be the Java thing, java - version reports:

java version "1.8.0_65"
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)

I have “org.openhab.io.myopenhab-1.8.0.jar” installed in the addons folder. Does anyone have any advice on how I can start narrowing the problem down?

afaik myopenhab needs at least java 1.8.0_101 :slight_smile:

That’s what my first though was. Is anyone aware of a decent guide to updating a Pi 3 regarding Java? I don’t remember how I did it before, and my linux skills are not great. I tried a few things before I made this post, but I as far as I could tell my version is fully up to date.

Edit: See here:


That worked perfectly, thanks!