Losing add ons

I noticed lately that several bindings keep being uninstalled:
the MQTT action
Mail action
Twitter action
and RegEx transformation

show to be uninstalled in the paper UI, I reinstall them and some time later they have disappered again.

They are really gone as their effect/functions, dont work anymore.

Cant find anything in my logfiles that seems related to this issue.

Anybody any idea??

Are you using the services file to set which bindings,persistences etc. are loaded?

not sure if i fully understand you.
I had the actions/bindings installed via the paper ui.
if there were any attached cfg files in the services folder that needed to be configured then i did… That has always worked
Recently though they disappeared.
reinstalled them and then suddebly disappeared again

opus is asking if you have ever used addons.cfg for any reason. You cannot use both addons.cfg and other mechanisms (e.g. PaperUI) to managed addons. The addons.cfg file will take precedence over everything else and automatically remove addons installed via any other mechanism.

1 Like

Thanks, I had the name of the file wrong. I’m sorry.

1 Like

ah, ok, thanks for explaining. Nope, never used addons.cfg.
I saw though that it said:

# A comma-separated list of actions to install (e.g. "mail,pushover")
action = 

# A comma-separated list of transformation services to install (e.g. "map,jsonpath")
transformation = map, jsonpath, RegEx,, XSLT

whereas i would expect those to be commented out like the rest?
RegEx is one addon i keep losing but JSONPATH is not.

I think this might well be connected to the sendMail problems I have been experiencing since a few days

I had the same thing happening and the solution was to add the name of the binding into the addons.cfg file where the bindings are comma separated just like the transformation list you posted. I never touched the file so my guess is this is because I chose the EXPERT mode when installing openhabian img. Until you add the name of the binding it will auto uninstall when u reboot.

thanks. I didnt choose expert mode and only some 4 of my addons keep uninstalling, but will give it a try

The fact that they are not commented out and not empty I think could explain the behavior you are seeing. Furthermore, the two commas after the RegEx and the fact that it isn’t regex can explain the RegEx problem you are having.

Somehow this file became edited and edited incorrectly (assuming case matters).

If you do not want to switch over to being required to using addons.cfg, I think the following steps will work.

  1. Stop openHAB
  2. Comment out all the lines in addons.cfg
  3. Delete /var/lib/openhab2/config/org/openhab/addons.config
  4. Start openHAB
  5. Reinstall the needed bindings.
1 Like

Thanks Rich, I will give that a try

thank you @rlkoshak . that seems to have solved the issue. Just commenting out in the addons.config already seemed enough
Thanks @opus for pointing the right way
Thank you @matt1 for your input