Lost location in semantic model

So, I’ve begun transition from OH2->OH3 and I’m building my semantic model:

I defined
2nd Floor
1st Floor
Living Room
Dining Room

I then put into each room the appropriate equipment. When I defined one piece of equipment, I accidentally put it into the wrong room on the first floor, so I went to edit it, got some errors and reloaded the page, now my “First Floor” and all of the rooms in it are missing on the semantic model page, but still exists on the Locations page:


I tried rebooting and also clearing the cash and restarting. I’m not sure how to fix this issue. Has anyone else experienced this problem?

Check the Semantic tags on the ‘First Floor’ item and ensure that it is set as a location.

Hi Sunny,

Thanks for the quick reply. I guess I don’t know where to do this. In the Semantic model, the first floor doesn’t appear at all, so there is nothing to click on. Is there somewhere else this might appear?


All Locations are Group Items.

All Items appear under Settings → Items.

You can find the missing First Floor Group Item there.

It might work to click the “show non-semantic” at the bottom of the Model page. If the Group still exists and is just missing the semantic tag it should show up after checking that box.

1 Like

@rlkoshak - thanks - I found it there but it seems that is is corrupt. When I click on it I get a blank screen and a ton of errors in the log:

Note: This item is “GroundFloor” but the label is “First Floor” - since I live in the US these things are the same meaning for me.

OK, assuming you’ve not done anything else since this started happening the easiest thing we can do to get you back to good is to restore from the automatic the backups.

Stop openHAB.

Navigate to $OH_USERDATA/jsondb/backup (e.g. /var/lib/openhab/jsondb/backup).

Identify the backup file that was taken right around the time that the problem first started happening for org.openhab.core.items.Item.json by looking at the timestamps on the files. It will likely be the most recent one.

Copy that file over the current one. For example.

cp 1633982215074--org.openhab.core.items.Item.json ../org.openhab.core.items.Item.json

Double check the ownership and permissions on the file you just copied. Then restart openHAB. That will undo what ever happened to cause the current JSONDB file to be corrupted.

If you are curious you can open the corrupted file (it’s just text) and look for something fishy. Though that will only tell you what, not how or why.

1 Like


There we go. That worked. I didn’t actually know there were auto backups. Appreciate the help!