Luxtronik Heatpump bug, hot water setting increments (on every water heating)

I have Luxtronik controller for heatpump connected to oh2.5 with novelan binding, why still well it worked untill now for many years. I started migration to oh3 but it is still not set up copletely with all devices i have, including heatpump, there were also some buggy setting items

Meanwhile i need to maintain oh2
this is the bug description
I changed hot water target temperature from 45 to 35 on openhab, for one week for costs saving
than hot water setting incremented on every water heating cycle by 0.5 C.

I can confirm that i have no script that is changing the hot water target temperature on openhab.
I know it is not helpful that i still run oh2.5.

From event log i didnt find the cause for change as i dont know how to diferentiate if the soure of change is luxtronik controller or openhab.

I can only confirm that the last time i encountered this behaviour the increments stopped at initial setting for hot water that was 45C since we installed heatpump many years ago. the bug i discovered this winter first time. i have to try making change on controler to se if bug shows up than also.

has anyone encountered similar issues with openhab bindings for heating as i also had issues with max thermostats that changed settings by itself when connected to oh2. But i have no issues with mqtt devices that i controll with oh2.