MagentaTV - Binding Problems

Hey guys,

at the moment I’m trying to include the MagentaTV binding Version 3.0.0 with Openhab3.

Everything else is working properly.

What happened?

  1. Installed the binding -> no problem
  2. MediaReceiver (401B) was found in INBOX and added -> still no problem
  3. configured the MediaReceiver (login-name and passwort) -> Status unknown.

Whatever I do, I can’t get the receiver in a working state.
If I send a command: -> “Channel operation failed (command=ON, value=control#mute): Pairing failed, result=-2”

The Thing is not able to connect and receive an UID. If I login in console and try to get an UID I always get the error: “An unexpected error occurred during execution.”

If I use a wrong Email or Password a different error occures. My Email is correct but its a gmail and not a t-mobile or t-online. I can log in into the customer center without any problem.

I read the documentation and a few posts in the forum. I think I have done everything correctly. Did I miss something?

Would be awesome if any1 could help me :slight_smile:

plus one - I have the same issue and can not find the solution :confused:

Hello Guys,

same for me. Also have a MR401B. And i get no UID via:

  • OpenHab UI
  • OpenHab Console
  • magentaTV Node.js Application
  • magentaTV bash script

Nothing works. Even in Wireshark i cannot see a userID. If i search for <userID> i get nothing. If i search for userID i get an empty field:
<name> userID </name>

Tried with Version:

  • The one which get installed via OpenHab UI
  • 3.0.0 (manuall installation)
  • 3.1.0 (manuall installation)

Also i have installed openHab on a Raspberry PI 4 and a x86_64 PC. Nothing works, same errors as reported.

please use the main thread for the binding

Hi Marcus, is there a plan to support the MagentaTV One receiver. That one is based on Android and uses Streaming for the TV Service, which is much more stable then the “old” Platform.

Let‘s say: I don‘t have one :slight_smile:
The question is: Is it based on the same software protocols or not. If yes it might be enough to add a new model number and all good. If it requires a new protocol I doubt that I find the time to dig into that.

Could you start the binding in TRACE mode? This should show discovered UPNP devices and we get the model id. I could add this to the binding and we see what happens.

  • stop binding
  • set log to TRACE
  • start binding