MagicHome LED strip changing color it self without any command

Hello. I have MagicHome Wifi LED controller RGBW. I installed WI-FI LED binding. Everything works well, but sometimes strip changing color it self without any command. In the logs there are no commands to change the color. It just appears that the color has changed. And the color value is very strange.

Has anyone encountered such a problem ?

Which Item should we be concentrating on in your log screenshot?

Does your MagicHome device have an infra-red or RF remote?

Look on Item “LED_table_color” and “LED_divan_color”. My LED contollers without infra-red and RF remote. Just Wi-Fi. Here is my *.things file :

Thing wifiled:wifiled:C82E475F9C4E “LED_Table” [ ip=“”, port=5577, pollingPeriod=3000, protocol=“LD382A”, driver=“CLASSIC”, fadeDurationInMs=1000, fadeSteps=100 ]
Thing wifiled:wifiled:C82E475F9886 “LED_Divan” [ ip=“”, port=5577, pollingPeriod=3000, protocol=“LD382A”, driver=“CLASSIC”, fadeDurationInMs=1000, fadeSteps=100 ]

and items:

Switch LED_table_power “Подсветка” (gClientRoom) [“A_light”] {channel=“wifiled:wifiled:C82E475F9C4E:power”}
Dimmer LED_table_white “Белая подсветка” (gClientRoom) [“A_light”,“brightness”] {channel=“wifiled:wifiled:C82E475F9C4E:white”}
Color LED_table_color “Подсветка” (gClientRoom) [“A_light”] {channel=“wifiled:wifiled:C82E475F9C4E:color”}

Switch LED_divan_power “Подсветка” (gPriemnaya) [“A_light”] {channel=“wifiled:wifiled:C82E475F9886:power”}
Dimmer LED_divan_white “Белая подсветка” (gPriemnaya) [“A_light”,“brightness”] {channel=“wifiled:wifiled:C82E475F9886:white”}
Color LED_divan_color “Подсветка” (gPriemnaya) [“A_light”] {channel=“wifiled:wifiled:C82E475F9886:color”}

Hmmm, interesting. The colour changes, but by a tiny amount: do you notice the change in real life?

I wonder if this is a number precision problem in the binding/openHAB/MagicHome/something else…

In real life this is a big problem. Let me explain : When the LED-strip OFF and her color changing then it turns on, even if the channel “power” is OFF.

I see LED_divan_power being sent an ON command. Seems reasonable that would turn it on.
Is that coming from some rule of yours?

Correctly noted, this is the result of the rule. But this was done in order to track the status of the strip in BasicUI. Without this rule, the strip simply lights up, and in BasicUI, the strip state is OFF. If the strip changes any state (color, brightness, white), it immediately turns on, and this is how I understood its normal operation.
The problem is that the color changes itself. :frowning:

Sounds like there are two issues then:

  • Changing colour without apparent input
  • openHAB status not updating, which you’ve masked with a rule (I’m assuming the WiFi LED binding should be updating the status correctly, but I don’t use it…)

EDIT: I’ve updated the tags on this thread to reflect the WiFi LED binding aspect of this issue.

Yes you are right. I think the problem with updating the status is related to the specifics of the control channels. The “power” channel has values (ON/OFF) and the “color” channel has values (HSB-value or ON/OFF). See the screen below :

I can’t turn off the light and leave the house now, because the LED-strip turns on by itself :slight_smile: Now the value of the highlight color has changed to these values.

I have 2 controllers installed. And this problem with both.

You are sending it a command ON. Whatever else may or may not happen, you are making sure your LED is turned on. Don’t do that if you don’t want it on.

If you’re trying to update something for your UI, update it. Use postUpdate, not sendCommand.

Let’s see whats left after that is fixed.

I wrote this rule only because when changing the color, brightness, or whiteness the strip turns on (without any rules). When changing the “color” channel to ON or HSV-value ( …,…,…), the “power” channel remains in the OFF state. You can check it yourself if you have LED binding and a controller. I think this is due to the fact that these are different channels and they are not connected in any way. They simply duplicate the ON/OFF actions. I will follow your advice and disable the rule or replace it with postUpdate. Let’s see what happens.

You should definitely follow the advice of @rossko57 and use postUpdate for your rule - all you actually want to do in your rule is update your UI, not send a second command to your device.

However, I don’t think that will fix the issue at hand. As you’ve described, even without the rule, your LED strip will turn on when its colour channel receives a new colour value. And there is something mysterious send a slightly different but still new colour to your device.

I’m out of ideas, but that’s mainly because I don’t use the binding. I also have a MagicHome device, but flashed with Tasmota. It’s integrated with openHAB through MQTT. Might be more hassle than you’re willing to put up with, though.

Tell me please, what “Module type” do you select in Tasmota? “MagicHome(34)”? Or something else?

I link to the Tasmota page in my description. From here I chose Arilux LC03 because I have the IR remote version.

Thanks. I’ll try to flash Tasmota one of my controllers. From your table, I have an LC02 device. I will look at the difference in work and let you know.

Note that there are two versions of the MagicHome device around:

You can sometimes identify which you’ve got from the outside, but it should become very clear once the box is opened.

I opened the box and saw this

There are no ESP. DO you now, how can I flash it?

Unfortunately it’s not possible, apparently:

Here is an excellent German video how to flash Tasmota on these Magic Home controllers. I recently did it myself.

Kind regards,