Mail will not more be send

Hello all,

I’m running two different OH3.2 system, with the latest upgrade, which have now the same error.
Mail which should send out triggered by a rule will not more send to SMTP.WEB.DE mail server.
The error which I can see in the logfile from OH3 is the following:

Now changes on the binding, no changes in the rule, no changes in the password etc…

Any idea what could be the problem?

PS: I tryed with a other public Mailserver ( The same error here.

Well the error talks about unsupported data type in multipart/alternative - the question might be what are you trying to send there?


Hello Robert.

I have arround 30 such of scripts running for everything. Temperature in room above ABC, or xyz switch on, etc.
Here is the line which will be triggert as an example:

val mailActions = getActions(“mail”,“mail:smtp:6cd5aa89af”)
mailActions.sendHtmlMail(“”, “Es hat im Garten zu regnen aufgehört.”, “Im Garten hat es gerade zu regnen aufgehört.”)

So nothing special.
And as said before. Mail sending has been working since 1/2 year now without a problem.


o.k., if it worked before then this is odd somehow… I think the issue is on OH sender side, the mail has not yet really been sent at this point.
Does it work if you use sendMail instead of sendHtmlMail, as then there is no multipart required?


See Mail binding errors sending mail UnsupportedDataTypeException: text/plaijn; charset=UTF=8.

It’s a known problem, an issue has been opened for it and the root problem is known but a solution is not yet found. It only breaks for some people some of the time. Watch [Mail] sendMail and sendHtmlFail errors for UI rules · Issue #11838 · openhab/openhab-addons · GitHub. When that issue gets closed the problem will have been fixed.

Rich, great to hear, or bad to hear, that is a knwon problem.

So I’ cross this fingers and hope for an quick fix in an update that will help to solve the real common used sendmail service on OH3.2