Mains plugged ZWave devices not routing?

Hello community,

i am trying to expand my zwave network to reach all floors and bought some mains connected zwave devices (2 Fibaro WallPlug and 2 Philio PAN06).
Thanks to habmin, including them was easy, but after learning in 3 of the 4 devices, none of them seem to be routing - at least in habmin, under “Properties” the “Routing” has the red crossed icon for all of these devices. As a matter of fact, all icons on these devices are red crosses - “Routing”, “Listening”, “Frequently Listening” and “Beaming”.

In a previous post, i asked about zwave routing, because it didn’t happen as expected - and it still doesn’t:

So, what can i do to make my zwave devices (at least those on mains power) expand the range to devices farther away?

Best regards,

Routing is handled by the controller. However the network chart in HABmin is likely not correct at the moment so don’t trust it too much since the neighbour update list isn’t working.

Ok, so disregarding how the network chart looks like, i still have those 3 devices connected to main with another battery powered device about 5m meters from one of then, not connecting to openhab and shown offline in habmin.

Does it make sense to edit the XML Files for those nodes and set routing to true (if possible)?

Changing the XML file won’t change anything. The routing flag comes from the device itself and can’t be changed - it just tells the controller if the device participates in routing. If a mains device shows routing=false, then that’s quite strange, but there’s nothing you can do about it.

I don’t quite get it - 2 of them are Fibaro Wallplugs (FIBEFGWPF-102-5), the other two are Philio PAN06. I already have a PAN04 in the network, which has the flag set.

How can i procede to find the problem? Exclude the devices and include them again? Let the network heal a few times?

What does the XML show - does it show the same status as shown in HABmin? If the XML shows that the devices aren’t routing, then this is probably the state from the device, but I would be quite surprised.

In this case, I guess you can re-include the devices, but I doubt it will change anything. Heal won’t change anything since these flags are not allowed to be changed by a device except during inclusion.

Hm, that was strange - there were no XML files for the 3 nodes. So i excluded them and included them again (one of them 3 times) and then there were XML files and the devices marked as Routing.

Then i placed those 3 devices where they should be later to see if they route traffic from other battery driven devices. Now there is a PAN06 about 7-8m (one concrete floor between) and a WallPlug 10-12m (two concrete floors between, one concrete floor from the PAN06 and about 5m distance) from the controller - the PAN06 connects to the controller, but the WallPlug doesn’t - because the controller is too far away, but the PAN06 would be much closer, and it doesn’t route :frowning:

I attached the controller XML and the ones from the two WallPlugs and the PAN06. The latter ones seem ok to me (me being no expert at all…), but the controller doesn’t show any Properties on Habmin, only 3 neighbor nodes, and Node 2 doesn’t even exist on the network…

Oh, and there’s lots of errors in openhab.log, but how do i find out which ones are useful to show? Most of them are like this one about Node 13:

2017-01-31 21:44:24.265 [WARN ] [ocol.ZWaveController$ZWaveSendThread] - NODE 13: Too many retries. Discarding message: Message: class=SendData[0x13], type=Request[0x00], priority=Config, dest=13, callback=221, payload=0D 03 70 05 10
2017-01-31 21:44:29.267 [ERROR] [ocol.ZWaveController$ZWaveSendThread] - NODE 13: Timeout while sending message. Requeueing - 2 attempts left!
2017-01-31 21:44:29.268 [ERROR] [l.serialmessage.SendDataMessageClass] - NODE 13: Got an error while sending data. Resending message.

node1.xml (1.3 KB)
node12.xml (13.4 KB)
node15.xml (9.3 KB)
node13.xml (9.3 KB)

Ok, i know you said that the Network diagram shouldn’t be taken too serious, but that’s what it shows me now - Nodes 3, 4, 5 and 6 being battery powered devices on all 3 floors, so there should be any of the other routing devices near. Node 4 is closest to the controller, Nodes 3 and 5 at equal distance from controller and Node 12, Node 6 very much closer to Node 13 than to the controller.

I’ll look at this tomorrow, but in answer to your question about which logs to show - you need to provide a DEBUG log - error logs don’t provide any information.

As I said, the neighbour list is not updated in the current version, so the network diagram doesn’t mean much - sorry.

Thanks @chris, i just set the log level to debug, deleted the previous log file and restarted openhab. I’ll let it run overnight in debug (healing at 2am CET) and get back to you tomorrow - do you want me to filter other messages from the log (only zwave set to debug, but some other bindings like knx and mqtt active)?

OpenHAB ran overnight, but with DEBUG on zwave, i have about 50MB of logs - how much does make sense to look at?
BTW: The zwave logviewer on your website is great! I ran the first part of the logs through it, but i can only make out that most devices don’t discover any neighbors.

@astrnad did you sort this out? I have three door sensors that have a hard time communicating with my controller and thinking of buying some mains powered devices to extend the reach of the signals. I have ordered two Nexa wall switches but don’t know if they will route.

Hi Martin,

from what i know, every mains powered device is a routing device.

Try uninstalling the stable binding and installing the zwave binding from market, that’s what fixed my network.

Best regards,

Thanks! I am already running 2.1 of the z-wave binding. :slight_smile:

Hoping my switch devices will arrive today so I will try them out later tonight.