Managed to pair a Sonoff RF with a common 433mhz remote control!

Tags: #<Tag:0x00007f616ed547e8> #<Tag:0x00007f616ed54658> #<Tag:0x00007f616ed54568>

I read a lot about which remote controls are working with the Sonoff RF and which not I tried it myself.
I own an ELRO type (AB440R) and an old REV type (hardwired code).
I had the relating switches incooperated with OH (the Sonoff switches, running Tasmota, are to be the replacement), so I know the needed code to send via a CUL-stick using the CUL-Intertechno binding.

Pushing the black button of the Sonoff quickly 2 times puts the switch in the learning mode (the red led does show only a short blink or with large gaps I didn’t wait for. It is not as bright as the green LED!!). Sending a signal now the red LED should show and the relay should switch. It worked on the first try!
The used Raw Code was: 000FFF0FFFF0
The Sonoff RF does only need asignal, since it reacts with switch the relay each time.

By accident I found out that the Sonoff does not only react on that signal, the first 5 key seem to be of no significance. In other words codes like: FFFFFF0FFFF0 or 00000F0FFFF0 could also be used.
I can send such code with both remotecontrols mentioned above, however I’m sure if all codes would work.

I also ordered a Wall Remote Control which was reported to be working with the Sonoff RF from Ali Express (needs a special battery), now I think I might go for a more common one which works without a battery.

1 Like

Long story short RF Bridge has problems decoding intertechno code correct.
If you know the correct codes sending works perfect.
Take a look here


and here

Thanks, I have a bridge, mine receives nothing, probably broken😕