Many Openhab3 Reconnect Log Entries

I’m seeing many mqtt INFO entries in the log view. Should I be concern with the messages? If not, can filter them out?

2021-01-21 05:53:49.880 [INFO ] [.reconnect.PeriodicReconnectStrategy] - Try to restore connection to ‘IP’. Next attempt in 60000ms

2021-01-21 05:53:49.892 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘IP’ with clientid 123345

1 Like

Same do I. Every minute. For days now.
I already deleted the MQTT broker from and re-installed it in openHAB. Gave it a new ClientID so I could differ. The broker and MQTT is working though. But in the log it’s steadily reconnecting.
I would like to add that I upgraded from OH 2.4 to OH3 and I took some installed addons with me. So the MQTT broker, but currently there is only one listed in openHAB (with this ClientID).

2021-02-09 21:02:41.820 [INFO ] [.reconnect.PeriodicReconnectStrategy] - Try to restore connection to ‘’. Next attempt in 60000ms
2021-02-09 21:02:41.832 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘’ with clientid openHAB3-ClientID

Same here. Could this be on purpose?

When I today restarted OH3 i read in the log that it connected to two brokers:
2021-02-11 14:16:10.953 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘’ with clientid OH_MQTT-ClientID
2021-02-11 14:16:11.093 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘’ with clientid openHAB3-ClientID

The openHAB3-clientID being the current one, the OH_MQTT-ClientID I deleted. Via UI, nowhere else.

But although openHAB3-clientID does its service, it still tries to reconnect every minute.

As there are several community members having these entries and I did not read of a solution yet: Can somebody help with this?

I have the same issue on openhab 3.1 M1. Every 10 seconds a connect / reconnect towards my MQTT broker.

I have a Mosquitto broker running in Docker. Did a quick search on github but could not find an issue. Not sure what to do about this, anybody found a solution is it a bug?

Search recent threads about System Broker. It’s un unwanted legacy from OH2 that seems to get invoked for some.

Ok, I managed to solve it. I stopped openhab. Cleared the cache and tmp directories and removed the mqqtbroker config (all under userdata directory). Started openhab again. No more repeating MQTT messages. Good!

1 Like

I tried that. But did not work for me. Still repeating log messages.

I encounter the same problem with OH3 M3. I had never OH2.x but started from scratch with OH3 main version and upgarded via M1-> M2 → M3. Issue came up in M2 BUT ONLY because I started to use the MQTT broker (before Zigbee binding directly)
Even changed the 60 seconds to another number in both MQTT entities (under things and on the binding). BUT I still get this problem now for weeks…

If I remember correctly, I once created via the UI another MQTT broker thing instance (system one) and deleted it. Maybe this could cause the problem? Is there any chance to tidy up the UI generated items?

Thx for any hints - it seem to be multiple persons with this problem and no solution!

checked the log and it seem to be the MQTT System Broker which is automatically created (by the binding?) and an INBOX item - therefore I cannot “delete” it, as it comes up again every system startup:

2021-04-02 11:02:47.063 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘mqtt:systemBroker:MQTT’ to inbox.
2021-04-02 11:02:47.075 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘’ with clientid b9916d98-5d81-4932-a8b4-7378776ea114

Any clue why this is happening? I do not need this item!
Deleting it from the Inbox does not help with the error message.

checked log files a bit more and found the problem (for me).
It is the MQTT system broker, which is configured on “Other services” → " MQTT system broker connection".
If the IP adress is deleted there, it will give one “warning” in openhab.log that it is missing BUT not try to connect → this SOLVES for me the annoying log entries.

Reading some forum entries, this seem to be a legacy? internal broker → so not needed anymore…
Maybe a maintainer can “tidy up” the binding?


Thanks. It worked for me as well.

Yes, works. No attempts / log entries anymore. Thank you