MAP Transformation Service Not Working

I have tried allot of things to get the Transformation service to work. Restarting Openhab2 services. Uninstalling and re-installing transformation services. Adding the space after [ .

Failed installing ‘openhab-transformation-“map”’: Error restarting bundles:
Cannot get service reference for transformation service of type MAP
Cannot get service reference for transformation service of type [MAP

Ideas? Lots of errors.

check if you can remove the " around the word map (check file /var/lib/openhab2/etc/org.openhab.addons.cfg also)

how are you installing the bundle? which OH version?

Those entires are logtail logged events. I am at the latest and I did run the openhab ian-config to check for a newer version. Installing with Paper UI

Thanks. I did find some references to listing all the add ons to the admins.cfg. Is this the case?


are you using the /etc/openhab2/services/addons.cfg file or you are installing bundles (addons) from PaperUI?

anyway, try to remove the quotes around the bundle name in the /var/lib/openhab2/etc/org.openhab.addons.cfg and it should work.

Bundles from Paper UI.

Ok. sudo nano /var/lib.openhab2/etc/org.openhab.addons.cfg - found the quotes and removed them.

I restarted with a systemctl restart openhab2.service and these are the errors I no longer get the I no longer get the Failed installing ‘openhab-transformation-“map”’: Error restarting bundles

I do get these now:
2018-02-26 21:40:54.924 [WARN ] [.core.transform.TransformationHelper] - Cannot get service reference for transformation service of type map
2018-02-26 21:40:54.927 [WARN ] [.core.transform.TransformationHelper] - Couldn’t transform value because transformation service of type ‘map’ is not available.

For anyone looking in this forum ho to get transformation to work:
in PaperUI -> Add-ons -> Transformations install Transformation (e.g. MAP)

This is probably as well focumented in teh openhab docs and common knowledge in teh community . Still some still learn :slight_smile:

I tried also to install map-transformation but installation ends always in endless loop.
logfile says:
2019-01-27 18:32:20.083 [thome.event.ExtensionEvent] - Extension ‘transformation-map’ has been installed.

when trying to use the map service i get the warning in the logfile:

2019-01-27 18:32:32.589 [WARN ] [ui.internal.items.ItemUIRegistryImpl] - couldn’t transform value in label because transformationService of type ’ MAP ’ is unavailable

I’m running openhab 2.4 on rasberry 3B+