Marantz Power Off but no Power on


I’m new to OpenHab so please forgive my noobish question. I have a Marantz NR7200 receiver. I installed OpenHab 2 with the Marantz binding. It found my receiver.

I am able to power it off, but it won’t power on.

I tested this using both the HTTP and Telnet protocol. It seems to me that the Marantz bindind is sending the wrong command? Because the official Marantz app on my phone is able to power it on.

Btw. i removed the official Marantz app from my phone, to make sure it’s not interfering.

Am I doing something wrong, or did anyone else encountered this issue?

Kind regards,


I seen to be able to confirm this on a Marantz M-CR611. I have the binding installed but have not used it much. But it seems to also fail to turn the device on. There is a single entry in the log

2020-01-05 17:24:22.656 [WARN ] [ector.http.DenonMarantzHttpConnector] - Error null while sending command

Hi Morten, i just started using OpenHAB. Can I ask you where this log is located? I am a software dev myself, maybe I can fix the problem…

Maybe the WOL binding could work for turning it on?

I tried to dig a little deeper but did not find anything conclusive. I did see a ‘No route to host’ which I think could be the problem. Maybe the device is so sound asleep that it cannot respond to wifi IP messages. This does not explain how the app does it though.

The log files and how to enable additional logging are explained here:

To enable additional log messages in this case, use:

log:set DEBUG org.openhab.binding.denonmarantz 

Happy hunting :grinning:

Yes, that might work. Possibly followed by an ON command.

It works for TV’s but I’m not familiar with the equipment your using so I threw it out as a suggestion and yes with an ON command. :wink:

Let us know if using WOL binding works for you.

1 Like

Just tried, the NR7200 does not respond to WOL packets. When the device is in standby mode the telnet interface isn’t listening for connections, but the HTTP API interface is up!

Ok, did you check the debug logs? If the HTTP API is up then "No route to host’ as in my case makes no sense.

maybe when the device is off you cannot find it as it has no IP?
i have seen this cool feture on my smart TV :frowning:

breakthrough :partying_face:

Yesterday while I was sniffing the communication with Wireshark I found the solution.

The key to the problem is this:

  • Install the official Marantz App (in my case the IOS version on iPhone5)
  • Make sure the App finds/see the receiver
  • Turn the receiver on using the power button in the App
  • Wait a few seconds till the receiver is fully initialized
  • Press the same power button again in the App to turn the receiver off

Now immediately when you press that button, the App shows a dialog-box with a question. Something like “Do you want to able to turn the receiver on/off from this App?”. Choose Yes or OK (whatever).

Now suddenly it works, you can turn off the Marantz receiver from OpenHAB2 and the App.

For as far as I understand it, this question triggers a state/setting change in the Marantz receiver which allows it to be turned on/off remotely. It probably keeps the API or network functions running while the receiver is in standby mode.

This wasn’t the case before. Because before all this, when I switched off the receiver from OpenHAB, the receiver “thing” inside OpenHab changed from “Online” to “Offline - Communication error” (or something like that), and now… after this procedure… the thing stays in state “online” even while the receiver is in standby mode.

I tested it over and over again today, still can’t believe it. But it works like a charm :slight_smile:

Hope this helps somebody…


Good find :+1: That’s a nice feature! It probably costs a little extra power in standby but very handy. I don’t remember seing that dialog but that is probably because I mostly use the IR remote instead of the app.

You can mark your answer as the solution to make it easier for others to find.