Marketplace bindings missing in Add-On Store

As the title says, I am missing marketplace bindings in the Add-On Store. All bindings including the Title „Market Place“ is gone.
Setting „Activate Community-Market Place Add-Ons“ is enabled.
Is anybody else having this problem?

Screenshots ? I don‘t face such an issue…

This is how it looks like with a marketplace binding I added in an earlier version:

And this is how it looks like if the remaining marketplace binding has been removed:

I am on 4.1.1 release build

Furthermore, all market place „Widgets for the Main UI“ from the UI tab is gone, too.

Of course, cache is deleted and openhab has been restarted.

Any idea? Are there any settings in configuration files I could check?

Any errors in the browser console when the Add-on page loads?

Good point. But no errors or warnings


I remember there was a previous issue like this somewhere on the forums a while back, but I can’t find it again. And, of course, I don’t remember what the resolution was.

Are you referring to the Firefox and caching issue?

@Oliver2 do you use Firefox? Tried different browsers?

No, I don’t believe this was related to the caching issues, and Oliver is on 4.1.1 which has the patch for that issue.

That problem seems to be browser-independant. I am using chrome on Windows-PC and Safari on iOS.
I also remeber problems a while ago with market and cannot find the thread, too. If I remember correctly something had to be added manually to a cfg file.

Then I’m out of ideas…

Do you see any marketplace errors when you start OH?

And what’s the status of the Market place bundles in the karaf console:

bundle:list | grep Market

They are both active

156 │ Active │  80 │ 4.1.1                  │ openHAB Core :: Bundles :: Marketplace Add-on Services
157 │ Active │  80 │ 4.1.1                  │ openHAB Core :: Bundles :: Community Marketplace Add-on Service :: Karaf

But that reminds me of a problem when I accidentally uninstalled the bundle „Apache CXF JAX-RS Server-Side Events Support“ (org.apache.cxf/cxf-rt-rs-sse).
Maybe that uninstalled another dependent bundles?
Where can I see which bundles marketplace is dependent from?

I face exactly the same problem. Also no marketplace binding:

Let me just add one observation. The openhab.log contains the following startup message:

2024-01-24 08:01:37.879 [WARN ] [ity.CommunityMarketplaceAddonService] - Unable to retrieve marketplace add-ons: Connection timed out

very early after the start of openhab

2024-01-24 07:59:16.086 [INFO ] [org.openhab.core.Activator          ] - Starting openHAB 4.1.1 (build Release Build)
2024-01-24 07:59:16.711 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to 'xxxx'.
2024-01-24 07:59:16.723 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to 'xxxxx'.
2024-01-24 07:59:16.725 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to 'en_DE'.
2024-01-24 07:59:16.726 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Measurement system set to 'SI'.
2024-01-24 08:01:37.879 [WARN ] [ity.CommunityMarketplaceAddonService] - Unable to retrieve marketplace add-ons: Connection timed out
2024-01-24 08:01:42.654 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2024-01-24 08:01:52.543 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.

Our IP address has probably been added to the blocked list of the marketplace community server😂

Have you tried to reinstall OH? Given that this is not widespread, it really sounds like something has just gone wrong with your OH instance. Backup → reinstall → restore might just be the quickest path to a fix.

Will do.
I noticed, that marketplace bindings disappeared from our demo, too.

Well, that just adds to the mystery, because when I load up the demo they are all there:

So, that at least narrows it down to something about your network or browser configuration, I guess. What that might be I have no idea.

Well, it is getting even more mysterious. Now the binding marketplace in the demo is back. But not on my production system. Really weird…

I have created a backup, stopped the server, restored from the previous backup without any impact.

Should I reinstall in between (remove and reinstall openhab package)?