Max! Cube loses all settings with OpenHab

Hi guys,

I have connected my Max! Cube with OpenHab and I always experience the problem that after about 3-4 days the Max! Cube binding cannot get a connection anymore to the devices to update the data, also when I then connect to the Max! Cube via the browser interface all devices on the cube were unregistered and basically the whole cube reseted to factory default as it seems.

Is this a known problem of the binding?
Or maybe my Max! Cube is defective?
The cube is connected with USB on my router fro power if that matters.

br
T

2 Likes

Hi Terra,

Just to let you know: I also use the cube to communicate with the Max thermostats. No issue (besides some I/O errors which seem to be normal since the systems responds as needed / expected).

However: I don’t use the router to supply the power to the cube. That maybe an issue (but since the cube stores the configuration internally and a power dip doesn’t affect it, I am not sure what the downside of this could be). Anyway: I would give it a try to use a separate powersupply.

You are aware that the PC software does an exclusive connection? (you have to shut it down before openhab can use it again)

Best regards, H.

Hi!

Thanks for the hint with the power supply. I will test this in the next couple of weeks.
It would be quite stupid if the cube looses all settings because of a short power failure, I hope it is something else…
But good to hear that it works for other people and it seems not to be a general issue.

I am aware of the exclusive access of the MAX! software. I always stop it on my macbook as soon as I am done with it. I also see that OpenHab then starts communicating with it again so no problem there. I have also configured OpenHab to be non-exclusive with the connection as I thought this might be the cause.

btw. I am using the latest Max! software 1.4.5 on my MacBook Pro

br
Terra

Is your problem indeed solved with the other power supply?

It would be very unusual for the cube to lose it’s configuration by normal usage. So I would say that either the power or the cube is defective.

Even concurrent usage should never trigger a reset.
So unless you send a factory reset, it should never happen.

Unfortunately not :frowning:
It lost the configuration again after some time.

I am now trying to only use the Windows MAX! app. In the past I switched between the Windows and MAC App. However lately I only used the MAC app so I don’t think this will solve the issue…

I can’t really imagine how the binding could do this.Hence it may be some sort of hardware defect.

However, just to be sure and to better understand what is truly happening.

  1. What exact version are you using? (OH1,OH2, date/release)
  2. Can you log at the most detailed level (TRACE see the maxcube OH wiki page how to do this) and mail this (alternative make a issue in github and paste it there)
  3. As this is a special case, and the forgetting of the can be manifesting in 2 ways can you use putty / telnet client to connect to the cube (telnet [your cube ip] 62910 or use e.g. putty connection type=telnet and with port 62910)
    before and after your cube is reset.

it should give some lines with starting with H:, M:, C:L: etc

Hi,
I had the same with my MAX!Cube. it couldn’t connect anymore and lost its settings every few weeks.
For me it is solved since I switched to exclusive mode in the openHAB binding. I assume that the frequent polling of the MAX!Cube in non-exclusive mode is triggering a bug on the cube which leads to the configuration loss.

1 Like

@dominicdesu,
Do you know how the message looks like when that happens? Which lines are still showing? I assume h message is still there. I can imagine m message v can easily corrupt indeed.

As I was developing the reset and update functionality I many times wiped the info, and found also ways to restore parts again.
If this corruption happens often I can possible make some save and restore settings option

@marcel_verpaalen, unfortunately I don’t have logs anymore, as this was a relatively long time ago.
I remember that I used a tool called MAX!Backup (seems to be not maintained anymore) quite a lot that time to restore my configuration as I didn’t want to pair all devices again and again… so a backup & restore functionality would be really useful :slight_smile:

personally for me the binding did not work (it constantly disconnected from the MAX! Cube every second day). What I did basically, was to take the MAX! libraries from their application from Windows (jar files) and wrote a separate binding that was using MAX! original libraries for communication. The binding is working for half a year now without any interruption in service :slight_smile:

After several weeks of testing the whole setup again and again I gave up and I think the cube has an issue. I am sending it back now and wait for a replacement :confused:

Even without touching the cube and disabling the OpenHab binding it lost the settings after 4-5 days. So I think it is unrelated to OpenHab.

What I tried:

  • Different Power Supplies
  • Exclusive Connection ON and OFF in OpenHab
  • Only maintain it with Win10
  • Only maintain it with OSX
  • Several Factory Resets
  • Enable/Disable OpenHab Binding

br
Terra

Interesting - I had a similar problem.
I’ve primarily relied on the Max!CUL solution (which I wrote), but there are nuances to the protocol with the Max! devices that make it a bit clunky/unreliable.

Back to the cube - do you have it connected to the eQ-3 internet service at all? I was wondering if that was causing issues?

I’ve been suffering from the same issue for almost a year. No MAX client software update nor openhab binding update helped. Would you be so kind and share the results of the replacement?

Thanks,
Mihaly

I have now given up, my replacement device showed the same symptoms 4 weeks later.
I will send the whole system back for a refund…

I wonder if a faulty thermostat or window contact causes this…

So far I never had it connected to the internet service of eQ-3

I faced the same running openHAB 1.x.
Since I am testing openHAB 2.x and have the Cube connected to it, no more loss of configuration.

I haven’t tested OH2 yet, but this sounds promising.
Was there any big change made for the OH2 MAX! Binding compared to the OH1 version?

Yes, as far as I understood.

Yes, indeed there are significant changes from OH1 to OH2. Esp on the networking side it was mostly rewritten to be much more stable and to avoid the OH1 issues around double connections when sending commands and multiple commands beging send if you control the temp with a slider.

I also added a few more experimental features like refreshing the actual temperature (by changing the temp every xx minutes with a half C) and e.g. you can now include new themostats from OH directly and change the thermostats names.

recently I ported the network changes back to OH1m but they have not been incorporated yet.

1 Like

Cool!
I will try it now with OH2. Let’s see if it still resets after some days/weeks.

Thanks for your effort :slight_smile:

Update from my side.
Since I use OpenHab2 the Max! Cube has not lost the settings. So it seems the issue was related to the OpenHab1 binding.
Working for 1 month now.