Members base type "Color"

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: OpenHAB 3.0.1
  • Issue of the topic:
    Hello: I have a newly set up openhab 3 system, installed using the openhabian image.
    I am pretty new to this, and i just started discovering all the things that i have, and creating items and equipment to control them.

All this goes pretty well, except i have an issue with light color bulbs and group control.

I have a couple of color lightbulbs that i want to control together. I was able to create a group for them (it is an equipment associated with the color temperature points of the lightbulbs), and when I set the Members base type to “Dimer”, i can dim the group up and down with no issues.

I wanted to be able to control the color of the lightbulbs too. so i tried to create another equipment where I associate the color points of the lightbulbs. But I realized there is no Members base type “Color”. So I cannot control the color of the group.

I also tried to create an equipment that contains all the points of the lightbulbs, hoping that I would see the same interface I see in the equipment autogenerated from the thing itself (the interface contains a color wheel, a switch and a slider), but this did not work either.

Can someone point me out to the right direction on how to do this? or if it is even possible?

I would like to post the configuration text files, but i have created everything from the user interface, and I do not seem to be able to find the text files on my system (no .items file). if someone could point me out to where can i find them, i will be happy to post them.

Thank you very much!

  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

First of all, that’s not how Equipment and the semantic model is supposed to be used. The model is supposed to represent the physical layout of your home automation. Physically you have two light bulbs. You don’t physically have one dimmer and one color control Equipment.

There are limitations in the model, in particular any semantically tagged Item can only be a member of one semantically tagged Group. If you continue down this path, you’ll pretty soon need to put one of those Dimmer Items (for example) in more than one Equipment and that won’t work.

No Point, Equipment, or Location can be in to two or more Locations at the same time. No Point or Equipment can be part of two or more Equipment at the same time. That doesn’t make physical sense and attempting to do so will break the model.

So you should have one Equipment for each bulb and that Equipment would have a Color Item and a Dimmer Item for the Color Temperature (I’m guessing). You can send Dimmer commands to a Color Item so you can treat them as if they were a Dimmer. There is no need to create separate Items.

Now for the Groups. You can have Groups outside of the semantic model and any semantically tagged Item can be a member of any number of such Groups. So you would create a Group from the Items menu and select Color from the list for the type.

And this leads you to the original problem. Color isn’t listed! And it should be. I’ve created an issue:

As a work around you can define the Group using the .items file syntax using “Add Items from Textual Definition” to create the Group:Color.

I’ve gotten around this by creating an equipment with points for color, dimmer, and color temp that have the respective channels for both bulbs (in my case) linked to each point instead of a separate equipment for each bulb and trying to group them. It seems to work just fine in all my testing, although I don’t have a need to control either bulb separately so you’d probably have issues with that and this approach if you needed to.

That’s perfectly reasonable. Logically, the light bulbs are part of a single Equipment in the way you use them so combining them make sense. So long as those bulbs’ Items do not appear in some other Equipment.

Hi again,
The answers have been very helpful, so i will be trying, first changing my semantic model a bit, and then defining some of the groups through files.
Talking about that, is there any good tutorial on text file definition? i basically started with openhab 3 and don’t know much about it.

Note, I did not say to define the Groups in files. I said to use the “Add Items from Textual Definition” option.


Then use the syntax that you would use to define them in a .items file. The UI will even check the syntax as you go.

1 Like

Hey rlkoshak:
I tried this, however, i was not able to get it to work
Group:Color livingroom_lights “Living room lights”

Creates a group and sets the category to color, but does not set the base member type to color…so the controls do not show up:

What am i missing?

Override the default stand alone widget and default list widget Item metadata and define the colorpicker controls there.

This also does not appear to work. Selecting “oh-colorpicker-card” as the stand-alone widget (i choose the color wheel module and the brightness spectrum module, but i also tried different combinations, as well as single items). Leads to a blanc control cell, as shown below:

Any other ideas I could try? I notice that the lights themselves show NULL on the upper control cell, and when you click on them, you get to the controls. How can i get the same behaviour in the group?

Additionally, tried using a slider as a standalone widget for the group. This works with no issues.
Could the bug you opened be related with an issue that is more complicated than just the display of a type?

I don’t know. I don’t use color bulbs so have no idea. But it is more of a problem hopefully that will come out in that issue. If not another issue can be filed.

Sounds good, thanks for your help!

Hello, I am trying in vain to create a member group of the type Player. Unfortunately, there is no selection for this either and adding it manually does not work either. Will there be an update in the near future? Any other ideas as a solution? Regards

Nobody can help?

What goes wrong? You can create a Group with no sub-type at all (no “member type” in GUI terms) and have any type Items as members.

Do I see when I filter member by Play how many are currently running (for example Alexa)? And can I then also say that I put the whole group on pause when I leave the house for example?