Mi Smart Antibacterial Humidifier not recognized

Hi,

I want to use my Mi Smart Antibacterial Humidifier which is supported with Xiaomi Mi IO Binding.
The Device Model based on the documentation is “deerma-humidifier-jsq”

In my system it is discovered automatically, but with “deerma.humidifier.jsq5” Device Model and with thingTypeUID: miio:unsupported.
In the Channels section I can see only Power and Experimental. I tried to used the Power, but not working.

If it is supported why the channels are wrong? How can I set it to work?

Thanks.

It is cuz your version is unsupported.
Try the other switch (the one that builds experimental support) and share the created file

Hello, I have the same model, I am able to see that created file, but unfortunately to all get_prop command it responds with:

{“id”:15,“error”:{“code”:-9999,“message”:“user ack timeout”},“exe_time”:4030}

But the response to info command works…
I tried different commands using miiocli, and I am not able to get any property. I can help with supporting this device, but I don’t know where to start. What I found on google is that someone made this type work, but on home assistant. I don’t know what they did to get this work.

file: Info for deerma.humidifier.jsqProperties: OnOff_State -> 15, Humidifier_Gear - - Pastebin.com

Hi,
for other reasons I replaced this humidifier, and the new (SmartMi Evaporative Humidifier v2) works correctly.
So I can’t help in this thread anymore.

Hallo @CsabaR

Seems this is a miot device based on the responses.

Can you try the same for the channel with name (experimental) Create experimental support for new MIOT protocol devices (it is available in the recent version of OH) and share the result.

OK, I tried it in OpenHab 3.1.0.M4, I will try in 3.2.0.M3, I hope this MIOT channel is present in that version.

yes it is in M3 indeed

OK, that channel was there, the file is different now, but still no responses for the key properties…
still many:

{“id”:4,“error”:{“code”:-9999,“message”:“user ack timeout”},“exe_time”:4010}

file: test-deerma.humidifier.jsq5-20211027-154857.txt - Pastebin.com

If I add new miio:basic thing with the model deerma.humidifier.jsq5, then no channels are present

I see… that is indeed odd.
Will do a bit of research on this device.

Maybe you can repeat the test while changing the communication to cloud (in the thing config)
I see that there are now sone devices that don’t allow local communication. As this device rejected all commands except for the info command, it might be one of those

According to this it should indeed be a miot device…

Maybe try the same test once more with cloud (first delete the file in the H:\Private\OpenHab3.2.0.M3\conf\misc\miio\deerma.humidifier.jsq5-miot-experimental.json to bring it back to unsupported)

Good news, yesterday I found that it stopped working even in Xiaomi Home app, so maybe it was fooled by too many failed attempts… So what I tried first was just disable and enable the wifi connection with button on back side. It started to respond to Xiaomi Home app, so I tried that generated file from newer OH in older version of openhab and it worked (maybe I did it twice, I don’t remember what I tried exactly) But now all channels are working.
BTW it is strange that when it didn’t work in Xiaomi Home, it was showing some values, but if I tried to make any change, then it was reverted back to previous value. (Maybe cached values on cloud?) This is why I didn’t notice that something is wrong, until I wanted to change something in app…
So fortunately this works even locally, I don’t have to use any cloud (just for getting the token), which is exactly how I wanted to control anything in my home.

Good… which of the 2 filters/method works?
The miot one or the regular one.

Can you share which are the working channels so we can add support for the device in the regular binding

It was the miot type.
I can share the generated .json file under conf/misc/miio .deerma.humidifier.jsq5.json (4.3 KB)
Every property works but I had to modify it a little, maybe because of some bug in the OH. I changed the format to use percentage sign %% instead of %unit%, because when I clicked on Analyze, the chart was showing percentage unit, but the numbers were in range 0 to 1 (e.g 50% was shown as 0.5%, even if in text form it was correct)
Maybe one thing should be defined in that json file but I am not sure whether it is possible, or how exactly it is supposed to work in OH (I am still newbie). For the target humidity I want to show a slider. Is it possible to define the default item to be a Dimmer type? If I leave the default item type Number:Dimensionless, then it is not straightforward to modify the setpoint. (I was able to do with Default widget metadata). Also I don’t really get it why the options for item type are Numbers with dimensions but also Dimmer, Switch etc, which I think describe different aspects of the same thing (one is the widget used, but other is the description of the measured quantity). In this example it is a dimensionless number but also a dimmer, so what is the difference? I also don’t get it whether it is an advantage to have type Number with dimensions over just plain Number (or dimmer). Does it have something to do with the units (which are clearly not working with %unit% in charts)?

great, I submitted it for inclusion