MIIO, Any point to adding Zigbee GW v3 device?

Hi all,
I am trying to work through some of the oddities I am facing with the Xiaomi smart devices that I have in my home and the integration with OH…

I have a Zigbee Gateway v3 which I have installed using the Mi Home Binding and it is working great.
However I have two device entries that are found by MIIO binging for the same gateway, I currently set them to ignore and leave it as that.

However I thought I would ask the experts on here what is the point of the gateway being accessed through the miio binding, am I missing out? Or is ignoring it in this binding the correct thing to do?



Anyone have any thoughts on this, I surely cannot be the only one running the Xiaomi Gateway and also the Miio binging.

No you’re not. The Miio binding is discovering every device that speaks the Miio protocol. The gateway does speak this protocol. But the gateway also has the developer mode. The MiHome binding uses the developer mode, where the gateway cummunicates in as easily accessible format.
If you turn the developer mode off, you still can discover the gateway with the Miio binding.
Using the Miio binding for the gateway is not of any advantage compared to the MiHome binding. By ingoring it you just do the right thing.
But if you want to play around and have a look by yourself, you can have both things at the same time, one from MiHome one from Miio.

Thanks for the response.
I actually did end up adding the Gateway to both just for cleanness in the logs and less ignored things under control in Paperui.

Interestingly I have found the gateway device to be really useful under MiHome binding.
The one thing I cannot seem to enable or disable is the ‘Alert’ this is triggered when a water detector for example is set off and the light on the GW flashes and siren sound plays.
The only way I have so far found to stop it is via the Mi Home mobile app anyone know a way to do it from OH through the bindings?



I only can think of sending 10000 to the gatewaySound channel like in the example rule…

rule "Play quiet knock-knock ringtone with the Xiaomi Gateway"
    // Item ExampleSwitch changed to ON
    sendCommand(Gateway_SoundVolume, 2)
    sendCommand(Gateway_Sound, 11)
    Thread::sleep(2000) /* wait for 2 seconds */
    sendCommand(Gateway_Sound, 10000)
    sendCommand(Gateway_SoundVolume, 0)

Perhaps its easier to build the alarm yourself as a rule, then it’s not as hard to switch it off :slight_smile:

I did try changing the sound but it did not stop the light from flashing.

I had considered setting up a rule for OH to perform the alert instead but to be honest the sensors if part of a security or disaster setup are far better being able to talk zigbee to the gateway and it alerting the users that way its the least amount of components to fail and hence highest reliability,

I am not so not keen to go down the path of adding OH into setting off the alert, I am fine with it being involved with it cancelling the alert by a triggered event instructing it to do so, with the Mi Home mobile app acting as backup if needed to cancel the alarm, and of course if really needed I will simply unplug the gateway :slight_smile:

Thanks for you thoughts


If it stop playing the sound, it means you just were able to override the alarm sound command.
then you’ll propably be able to override the light as well. give it full brightness for 500ms and then switch it off.

tried all types of brightness commands and on/off to no avail :frowning:

Too bad :frowning: