MiLight Ibox 2

Hi Guys,

Im really new to Openhad2 and have been through most of the study material. However I am having a bit of difficulty being able to control my RGB LED through MiLight iBox 2

I read about every single form on OB2 for the MiLight setup and im still struggling. I would really appreciate some help.

Set up :

Rasberry pi 3 B+, with openhabian installed
MiLight Ibox 2
MiLight LS1 Smart LED controller that connects to the iBox 2
RGB LED strip that connect directly to the LS1

Additional info :
I have connect the iBox 2 to my home Wifi network using the app that came with the iBox2. I am able to control everything fine through the app.

I have added the MiLight Bridge(iBox) to my things and shows that its online.

When I click on the bridge I do not see any channels (Picture attached).

Can someone please run me through this entire setup from adding the binding through to actually controlling the lights through OB2.

Thanks in advanced, all the help would really be appreciated.


Update :

I have also added the WiFi LED Binding binding-wifiled - 2.4.0. However that shows offline too.

You have the Bridge created and it’s working which is good. But a Bridge Thing basically represents your iBox 2. You need separate Things to represent each light.

From the binding readme:

Unfortunately Milight like bulbs have no back channel and can not report their presence, therefore bulb discovery is not possible.

so you can’t do automatic discovery.

I don’t use this binding but I suspect that what you need to do is manually create the Thing for each light. You should be able to do this from the Inbox by clicking the + and choosing MiLight from the list. Fill out the relevant information and you will have a Thing for that light. This is the Thing that will have the Channels.

The WiFi LED binding says in the docs that it only supports LD382, LD382A, LD686 RGB stripes


Thank you so much for responding. I will try that later today and provide feedback.



I There so I did as you said and this is was I see when I add manually.

However no matter how I configure it it still show offline when I add any of those things.


update :

So i got the integrated bulb(ibox) online

But when i change the controls nothing happens to the light.
Is there some code i should add in?

You need to create Items and link the Items to the proper Channels on the bulb Things.

Through visual studio?

Or PaperUI. Either one will work. If you have Simple mode enabled, Items were already created for you. I recommend turning Simple mode off though.

okay I created an Item

Below i have linked it to the bulk thing color channel.

but it still wont change the colour
and error pops up Error 400: bad request

At this point it’s an issue with the binding. I don’t use this binding so I’ve nothing further to offer in help. I know users are successfully using the binding.

There are multiple topics about milight. Ibox Milight (protocol version 6) is very broken in the binding, because it is reverse engineered (no official documentation). There is not a single project out in the internet that gets it right with those bulbs.

I recommend to sell all milights and get bulbs with a back channel (zigbee based for example).
And I’m the milight binding maintainer :wink:

@rlkoshak Thanks for all the help thus far. Its really helped.

@David_Graeff Ah bud lol i wish i knew this. Okay i will try get a Zigbee controller. if I’m unable to do some custom code

If you can code then I posted a way to sniff the packets from the app to the ibox here

Another way is to go with an open source hub that bypasses the ibox and speaks directly to the globes. See here

Hi @matt1

Thanks so much I will check the links out now.

I cant see to download the jar file. gives an error

That a pretty lengthy process to get a few led strips working.