MiOS Binding with GoControl Thermostat

I’ve just connected a GoControl GC-TBZ48 thermostat to my Z-wave system. Using it through the Vega Edge hub works fine, however when I try to remotely control the Mode of the thermostat via the MiOS binding I can only successfully turn the mode to “Off” every other mode request results in the error:the wrong format.

2018-07-14 21:15:47.901 [ERROR] [ding.mios.internal.MiosUnitConnector] - callDevice: The parameter is in the wrong format.  BindingConfig 'unit:veraedge,device:12/service/urn:upnp-org:serviceId:HVAC_UserOperatingMode1/ModeStatus,command:Heat=HVAC_UserOperatingMode1/SetModeTarget(NewModeTarget=HeatOn)', UPnP Action 'HeatOn'

Here are two item configurations that I can alternatively comment

String   downstairsThermostatModeStatus "Mode Status" (GDevices,GRoom2) {mios="unit:veraedge,device:12/service/HVAC_UserOperatingMode1/ModeStatus,command:Off=HVAC_UserOperatingMode1/SetModeTarget(NewModeTarget=Off)"} // This one works fine
String   downstairsThermostatModeStatus "Mode Status" (GDevices,GRoom2) {mios="unit:veraedge,device:12/service/HVAC_UserOperatingMode1/ModeStatus,command:Heat=HVAC_UserOperatingMode1/SetModeTarget(NewModeTarget=HeatOn)"} // This one gives the parameter is in the wrong format error

My sitemap file has

    Switch item=downstairsThermostatModeStatus mappings=[HeatOn="Heat", CoolOn="Cool", AutoChangeOver="Auto", Off="Off"]

The fact that it seems to work fine for Off but not any other modes suggest there is something I’m missing in the code. I’ve tried several variations of HeatOn, heaton, 1, heat but no dice I’ve also tried the default mapping file provided with the binding that doesn’t work either. Any suggestions?


Ok, its working. Removing the inline definition and using the internal defaults solved the problem. Not sure if I missed that originally or there was something else wrong.

String   downstairsThermostatModeStatus "Mode Status" (GDevices,GRoom2) {mios="unit:veraedge,device:12/service/HVAC_UserOperatingMode1/ModeStatus"}