Mios Item Generator error

Tags: #<Tag:0x00007faf835ef120> #<Tag:0x00007faf835eef40>

Trying to add a new zwave device of a different type. I pulled down the Mios Item Generator scripts again and ran them.

It seems as though maybe a new release of UI7 has removed the http://${MIOS_IP}:49451/data_request?id=user_data&output_format=xml function?

I can go to http://${MIOS_IP}:49451/ and it redirects to http://${MIOS_IP}:49451/cmh but the other link returns 404 not found but it isn’t a browser 404, it’s clearly a 404 from the vera.

Any ideas? Am I doing something wrong?

@guessed Do you maintain this? Sorry to call you out. I was able to nail up some of the items using examples I found but I still cannot get the generator to work and would like to see other item types available.

I just had the same issue - looks like miosLoad.sh makes the request to port 49451 on the Vera, but http://wiki.micasaverde.com/index.php/Luup_Requests examples seem to use port 3480. Changing the port number in the curl request worked for me.

Nice. Still get some weird errors but I seem to have a decent .items file now to work with.

I noticed after I posted that that guessed hasn’t been active since May. I hope he’s alright. He’s a great asset to this community.