Missing Availability of "Buttom" of Shelly1 in PAPERUI using shelly binding 2.5.5

Dear all,
after installing Shelly Binding (v2.5.5) i add my shelly1, which was discovered by paperui, the “Buttom mode” is not available - see pic (Using German language this is “Taste” - third entry)

What can i do top bring it up?

My shelly use frimware 1.7 and is configured to use buttom mode (in my eyes) - see:

Thank you for guiding me forward

  • Platform information:
    • Tinkerboard 2GB RAM
    • Debian 10
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: openhabian 2.5.5-1
    • shelly binding version: 2.5.5

Are you having problems with the device not working? Have you tried changing the Button Type in Shelly App to Edge Switch to see if that will work as I think button is just a description and you select the type.

The device works as a “Taste”
I use in Openhab:
Switch Shelly1 “Garagentor [%s]” (gruppeGar,gruppeKEL) [ “Switchable” ] { channel=“shelly:shelly1:e389d421:relay#output” }

And I´m able to use the switch.
But I didn´t get “answer” from the switch: means I push and the relais opens for 2 secounds and closed - fine
In the sitemap I see the switch turn to “ON” but turned not back when switch closed to OFF.
I have to hit the switch again goint to OFF.
Hidding again: switch go to “ON” and turn on relais for 2 sec.
Not going back to “OFF”

Sorry for this narration…

I think “Button Mode” which is not available can fix this behaviour?

Why is it not available?

BTW in shelly APP everything works fine an as expected: Hidding Button -> Button turn green “LED” on and 2 sec. later turn green LED off.


The button may be pressed, or not pressed.
The relay may be on or off.
These are two separate things, I wouldn’t think you wanted to link your button/taste channel to the relay topic.

According to your screenshot, the shelly is configured as push-button with momentary state. A connected physical switch should then work as you expect. For switch configuration in openhab you may check state profiles: https://www.openhab.org/docs/configuration/items.html#profiles

Allternatively as @rossko57 sugested, don’t use channel “Betrieb”, try “Eingang” or “Taste”.

Good answer!!
The origin of the topic is the question: why “Taste” is not available!

So can you explain your sugesstion to use “Taste” instead of … how can I! When not available?

Thanks for pointing me to the correct…