Missing Data in Sitemap


got a strange problem since yesterday. Hope you can give me a hint.

Hardware: Raspberry Pi + Homematic CCU2 + Tradfri Gateway
OS: Rasbian OS
openHAB version: 2.3.0

Issue of the topic:
I made an update to my CCU2 a few days ago and now some (not all) data of my Thermostat Stats are gone but only on the Sitemap. in Paper UI and Habpanel everything is fine and useable. The Temperature is even changeable and the Thermostat changes too in the Android App Sitemap but in the sitemap there are no Numbers visible.

Items configuration was not changed because it worked until yesterday
Sitemap configuration was not changed because it worked until yesterday

I am thankful for any idea where to look for the solution.

did you add the label to item or sitemap, like this

Number Livingroom_Temperature "Temperature [%.1f °C]"

I suspect it is due the UoM implementation.

I think a.tibi may have be on the right track

Number Livingroom_Temperature “Temperature [%.1f °C]”

thats the thing. i do have some that are working fine, one does only show the actual temperature and two does show nothing. all are configured in the same way. thats why i can´t find the problem. i think there must be something wrong with the sitemap but all items threre are also conf. the same way and some work and some don´t.

Have you found any solution for this?
I have started with openHab few days ago, Version 3.1.0.
The installation is on a dedicated machine, it is my 24/7 datacenter with openmediavault, no rpi, i.e. very reliable and stable connection settings and good performance.
From the beginning I got this strange behaviour.
In every case, when this happens, I have to reload the website.
All the other views seems to be ok, only the thing/item view for data does not include data after a short while…
It happens in desktop browsers (chrome, firefox, ms edge) and on smartphone browsers as well (chrome, firefox). It is very frustrating.
In the moment I just use the Homematic CCU3 with some window contact sensors and temp/humidity sensors, nothing special, as I said, I just started with all that.

I have only used the UI-ways to configure everything, nothing special, just clicking around… I have not added any data/sensor etc. manually, the tab view is generated by openHAB with all theses categories (e.g. sensors, locations, window, etc.). Interesting is, when I click “Analyze” for the temperatures, the current values are provided in the charts, but NOT as numeric value in the row list, only a “dash” is provided/shown.

Which information do you need for giving any hint to solve this issue?

Thanks in advance.

I found a similar topic which is not as old as this topic :slight_smile:

There a try with HTTPS is suggested:

I will check HTTPS later… But curios that this happens on my business notebook and my smartphone (business as well, but not managed by them, samsung s21).