Missing zwave device (OH2)


I’ve moved to OH2 and one of the devices that I added to the database and had working in OH1 is not there in OH2. Do I need to do something to get it added in OH2. In the past I would create a PR for it and if that is still the case that’s fine I can but the documentation wasn’t clear and I don’t want to do something that shouldn’t be done. I thought I saw where OH2 was more automated with the data in the database but maybe I misunderstood.

Here is the database device I’m wondering about. I added it about a month ago but I just made a quick edit on it.

Zooz Zen06

In theory, if it’s in the online database, then it should be included in OH2. Sometimes there are errors that mean a device gets missed, but generally it’s semi automated (I just have to copy the files from the export folder into a PR). I note though that the device you referenced is very new - the Zooz devices, with the Zooz manufacturer rather than another ID have only started turning up in the past month or two… The next thing to check is that the device type/id you have in your device is the same s in the database.

Lastly - what version of OH2 are you using?

Yeah, I added it to the database about a 1 - 1.5 months ago.

I checked the device type/id early on and it matches.

I just installed using openhabian about a week ago. I think I am misunderstanding the versioning a bit though. I read that it pulls the latest but I’m guessing that the database updates aren’t in the latest stable but more likely the nightly?

Let me pull the nightly and try that.

Real quick on a slightly different topic. In version 1.9 I could set parameters from the frontend or rules using something like


I don’t see any way around this but I use this type of thing for doorbell volume and such. Is there a way around it?

Thanks Chris

This is definately included in the binding, so it’s possible you’re running the stable version which doesn’t have this included (I just checked so can confirm this).

This is possible in OH2 - you need to add the channel to the database though (and I need to remember how to configure it!). I think you need to set the channel configuration to “parameter=XX”, where XX is the parameter number.

Thanks so much Chris. I’ve changed over to the nightly build and the device is there!

I will test this with one device soon to make sure I understand it. I’ll assume you don’t want every parameter listed there and only ones that it makes sense to be able to change “on-the-fly”.


Perfect assumption ;).


I am trying to add it but I want to make sure that I’m doing this correctly.

If I add it like this

I get this error

I looked at the list of channels but I don’t see any that make sense for some of the configuration parameters.
OH 2 Channel Types

Can you give me some guidance before I proceed?


I think what I used in the past was a simple config_decimal channel. We could add another channel type if it’s needed - how does this map - is it a set of discrete values (eg 1 to 10) or would it map to a dimmer (eg 0 to 100)? If it’s just 1 to 10 sort of thing, then I’d probably keep it generic and use the existing config_decimal.

For the volume it is a 0 to 10 range.
For another parameter I’d like to add it is a 1 to 100 range and then there is another that is 0 or 1.

So the list to choose from can be any regular channel in OH2 or config_decimal?


Yes - note that the “live” list of channels is here.

Since I’m editing this device in the database is there a way to delete an option that shouldn’t be there. See screenshot, the second option shouldn’t be there. Also, can the parameter such as this be read into a rule. This is one we spoke about briefly in the past but I don’t think you answered my question.


No - I need to do it. Change the name to “DELETE ME” - or something similar…

I’m not completely sure I understand what you want. I don’t think ESH provides the ability to change configuration in rules, but I’m not 100% sure as I’ve not kept up with the latest rule engine.

So for the doorbell the battery status of the button paired with the base station is listed in a parameter (42 as seen above).
I’d like to have it so when this parameter changes to low battery (255) I can check that via a rule and be alerted. If this parameter was listed as a channel would it read the value from the zwave device?

Yes - you could do this.

Awesome, thanks!

I promise once I learn some of this I’ll stop bugging you!

No probs ;). I’ve just updated the binding with the changes in database over the past few days - hopefully some of it works ;).

Ok, do those changes get listed in a PR? I’m updating the zw056 device right now and when I’m done I’ll request a review.

No - but you can see it here -:

Thanks! I see one of my changes so I’ll test it after the next build is done.