Modbus addon not work at openhab2.3.0

Tags: #<Tag:0x00007f2fc0678a30>
  • Platform information:
    • Hardware: PC
    • OS: Windows7
    • Java Runtime Environment: 1.8.0
    • openHAB version:2.3.0
  • Issue of the topic:
    I previous test Openhab at the older version, with Modbus binding and it works. but When I test it on the new version Openhab 2.3.0,and follows the instrcution of it. but it did not work.

    After I install the Modbus bingding with Pater UI, it seems the installed modbus version is 1.12.0. from other topics in the community, I get that the modbus version has update to a new verison. but why I could not install the new version directly on the PaperUI? and how Can it install the new version binding? could some one help me detailed, thanks very much.
    And when I install the Modbus binding on the PaperUI , the “Service” folder appear most binding configuration files blow shows.

    I think if I install Modbus bindings, only appear “Modbus.cfg” is more reasonable.
    And the “modbus.cfg” is not need in the new version Modbus binding, right?

The new modbus 2.x binding is only available in openHAB 2.4. You have to wait a stable release or switch to snapshot.

Hmm, actually, the modbus 2.x binding should be compatible with openHAB 2.3 stable as well?

However, the first “release version” of the binding will come in 2.4.0 addon bundle. So if you would like to use the new 2.x binding, you need to use so called SNAPSHOT version of it.

My understanding is that you can install snapshot version of openhab2-addons (linux), more information in the installation guide: https://www.openhab.org/docs/installation/linux.html#installation.

I think so too. In the past I have used 2.3 snapshot bindings with 2.2 stable.

Or you can just download one specific binding from Jfrog and drop it in your addons folder.

https://openhab.jfrog.io/openhab/online-repo-snapshot/2.4/org/openhab/binding/org.openhab.binding.modbus/2.4.0-SNAPSHOT/

1 Like

let me start with "I am an absolute newbee to openhab!

I want to use the new modbus binding to read data from my E3DC system.
I run Openhab 2.3 (stable) on a Raspi.
Installed the .jar file from the location above … and get the following errors in the log:

2018-10-18 16:12:58.339 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.modbus-2.4.0-SNAPSHOT(1).jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.modbus [200]

Unresolved requirement: Import-Package: org.openhab.io.transport.modbus

what went wrong?
any help is appreciated

Do you have more than one version of the modbus binding installed?

The error message says it: you need to install the transport as well.

@ssalonen
thank you for pointing me in the right direction.
where do I get the transport and how do I install it?
I was not able to find it … very likely because I am new to the subject and do not know where to look … sorry, if I did not see the obvious.

@ffr https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastSuccessfulBuild/org.openhab.io$org.openhab.io.transport.modbus/

super! works now.