Modbus (Solax)

@zlomennypez I used your instructions from this previous thread: Solax Hybrid X1/X3 Inverter RealTime Data and control locally, and for several hours all was ok, I’m on a single phase, not 3 phase, which I need to adjust for, but a lot of the data was reading correctly, but then after a while I noticed the values were not udpatign, and when I checked the log files I found lots of entries like this.

“Error with read: Modbus IO Error with cause=ModbusIOException, EOF=false, message=‘I/O exception: SocketException Connection reset’, cause2=null”

Connection with the WiFi dongle seems to be ok from the Solax app, and SolaxCloud, but for some reason the Modbus connection is failing. I’ve restarted OpenHAB and also restarted the rPi it’s installed on, but still the same issue persists. Any ideas I can try to fix this?

Try disconnect solax from the internet and restart connection. I noticed, that it was blocked from some reason. I made firewall setup to block incoming data to port 502 from outside a network and now it works.

Strange, yes, that worked, I used a router option to force the Solax dongle to reconnect and it’s working again. I’ll find the appropriate settings for a single phase inverter and post them up for others to use.

Following simple solution works for my WiFi-3.0:

curl <your wifi3.0-address>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<BODY><H1>401 Unauthorized</H1></BODY>
curl: (18) transfer closed with 17 bytes remaining to read

This simple trick seems to reset modbus at WiFi-3.0!