Monoprice Motion Sensor Issues- OH2

I’m having a heck of a time trying to get Monoprice Motion Sensors to work on OH2.

Set up as a contact item, I could not get any rule to fire (“changed to…”, “received update…”, ect)

I then set up as a switch since @chris 's website stated that the burglar alarm channel used a switch. I can capture the signal with “received update” when set up this way. The problem seems to be the signal it sends.

The sensor sends an “ON” signal when activated. It then has a hard coded 3 minute time that it will monitor and if no new movement it will send another signal. The manual says it should be an off signal, but OH2 seems to be interpreting (or it is actually sending) another “ON” signal.

This means that any rule I write gets activated twice, once when it is tripped and another time when it resets. I have tested this with “received update ON” and it activated on both signals.

So my question… is OH2 working correctly? If so, how can I create a rule that activates on the first signal but not on the second?

What firmware version are you using? I have two, one is the newer v8 that is working very well:

2016-10-30 21:07:57.842 [ItemStateChangedEvent     ] - zp3102r8_motion_sensor changed from OFF to ON
2016-10-30 21:07:57.861 [ItemStateChangedEvent     ] - zp3102r8_alarm changed from OFF to ON
2016-10-30 21:11:21.928 [ItemStateChangedEvent     ] - zp3102r8_motion_sensor changed from ON to OFF
2016-10-30 21:11:21.948 [ItemStateChangedEvent     ] - zp3102r8_alarm changed from ON to OFF

the second one here is an older one, firmware version 4.8.4, it is also working well.

2016-10-30 19:27:37.115 [ItemStateChangedEvent     ] - zwave_device_152e7642b11_node2_sensor_binary changed from OFF to ON
2016-10-30 19:30:54.060 [ItemStateChangedEvent     ] - zwave_device_152e7642b11_node2_sensor_binary changed from ON to OFF
2016-10-30 19:40:44.511 [ItemStateChangedEvent     ] - zwave_device_152e7642b11_node2_sensor_binary changed from OFF to ON
2016-10-30 19:44:07.722 [ItemStateChangedEvent     ] - zwave_device_152e7642b11_node2_sensor_binary changed from ON to OFF

On both devices, I am using the binary sensor channel, not the burglar(alarm). That channel does seem to follow the binary sensor without problem though. If you continue to have problems, try removing the device and re-adding it.

I have the firmware version 4.

I was under the impression that the binary sensor channel was for the tamper alarm and the burglar alarm channel was for the motion. I’ll try it out with the binary channel.

From your log it looks like the burglar alarm works on the version 8 firmware. Maybe it doesn’t work for the version 4 firmware? If that’s the case, I wonder if it should even be an option.

If both use the motion, is there no way to monitor the tamper alarm? Not that I really care, never used it before but I’d figure there was a way.

Tamper seems to be the burglar alarm on the v4 firmware. Like you, I have the channel defined, but do not use it for much.

It took awhile for me to get back to this but I’m seeing totally different behavior.

I’m not getting any changed state events. My sensor only seems to sends an update.

So to summarize… it is always shown as in alarm (or ON as a switch). If it senses movement it sends the alarm signal again. The sensor ignores all other motion signals for 3 minutes after which it will send another alarm signal once motion is sensed. There is no ON/OFF.

I did find a work around using “received update”, "thread::sleep, and a proxy switch as follows:

rule "Slider Motion Sensor Alarm"
     Item SliderMotionSensor received update
     sendCommand(SliderMotionSensorProxy, ON)
     sendCommand(SliderMotionSensorProxy, OFF)

This way it uses a proxy switch to indicate motion or not. The switch is set to reset after 3.5 minutes. This leaves a 30 second gap of not being monitored of which I’m ok. I’ll probably play around with it to see if I can reduce the time and still be reliable.

You shouldn’t have to do this, and I do wonder about the quality of our older hardware/firmware. The new one (v8) works like a champ and updates as it should, but the old v4 unit I have seems to fight with itself. Half the time, the temperature reads 0, or doesn’t update at all. The motion part seems to be fairly solid for me at least, but my sample size is 2 (yours and mine) and 2 of 2 seem to be having issues that do not make a lot of sense.

Hey Matthew, any update on this, I’m seeing the same thing with mine. I don’t get any triggered messages but these worked fine on Smartthings which makes me think it’s something with the binding.

I have one that works fine. My other sensor (the one I was initially setting up) stopped working entirely it seems. It doesn’t register anything anymore. I’ll be getting a new one to replace it at some point.

Just to follow up a bit. I’ve moved to another system (funny enough Smartthings…) and for the heck of it tried to include the sensor I thought was “dead”. Well, it turns out it wasn’t. Included immediately and is working fine. I have no idea why one worked and the other didn’t. Best of luck getting yours to work.

Are you using the binary_sensor channel with a switch item or contact? All of my motion sensors, and I think I have a couple of these, are Switches.

The switch_binary channel is a switch - that’s correct. Pretty much everything is defined as a switch by ESH.

Except for this one door sensor that is :wink:

If it’s a door sensor, then change the channel type to sensor_door and it will be classified as a contact if I remember correctly.