Mosquitto is not showing messages from tasmota device

I have openhab running in an lxc container (linux container). Everything seems to be configured correctly, but I cannot see any messages.

Tasmota device can establish a connection and sends data:


09:01:50 MQT: tele/%topic%/STATE = {"Time":"2021-04-28T09:01:50","Uptime":"0T00:02:57","UptimeSec":177,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":2,"SSId":"FritzBox7412","BSSId":"2C:3A:FD:17:AC:A4","Channel":6,"RSSI":92,"Signal":-54,"LinkCount":1,"Downtime":"0T00:00:06"}}
09:01:50 MQT: tele/%topic%/SENSOR = {"Time":"2021-04-28T09:01:50","ENERGY":{"TotalStartTime":"2021-04-05T19:48:08","Total":12.505,"Yesterday":0.902,"Today":0.007,"Period":0,"Power":1,"ApparentPower":8,"ReactivePower":8,"Factor":0.11,"Voltage":237,"Current":0.034}}
09:02:05 MQT: tele/%topic%/STATE = {"Time":"2021-04-28T09:02:05","Uptime":"0T00:03:12","UptimeSec":192,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":2,"SSId":"FritzBox7412","BSSId":"2C:3A:FD:17:AC:A4","Channel":6,"RSSI":92,"Signal":-54,"LinkCount":1,"Downtime":"0T00:00:06"}}
09:02:05 MQT: tele/%topic%/SENSOR = {"Time":"2021-04-28T09:02:05","ENERGY":{"TotalStartTime":"2021-04-05T19:48:08","Total":12.505,"Yesterday":0.902,"Today":0.007,"Period":0,"Power":1,"ApparentPower":8,"ReactivePower":8,"Factor":0.11,"Voltage":237,"Current":0.034}}
09:02:20 MQT: tele/%topic%/STATE = {"Time":"2021-04-28T09:02:20","Uptime":"0T00:03:27","UptimeSec":207,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":2,"SSId":"FritzBox7412","BSSId":"2C:3A:FD:17:AC:A4","Channel":6,"RSSI":92,"Signal":-54,"LinkCount":1,"Downtime":"0T00:00:06"}}
09:02:20 MQT: tele/%topic%/SENSOR = {"Time":"2021-04-28T09:02:20","ENERGY":{"TotalStartTime":"2021-04-05T19:48:08","Total":12.505,"Yesterday":0.902,"Today":0.007,"Period":0,"Power":1,"ApparentPower":10,"ReactivePower":10,"Factor":0.10,"Voltage":237,"Current":0.041}}
09:02:35 MQT: tele/%topic%/STATE = {"Time":"2021-04-28T09:02:35","Uptime":"0T00:03:42","UptimeSec":222,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":2,"SSId":"FritzBox7412","BSSId":"2C:3A:FD:17:AC:A4","Channel":6,"RSSI":90,"Signal":-55,"LinkCount":1,"Downtime":"0T00:00:06"}}
09:02:35 MQT: tele/%topic%/SENSOR = {"Time":"2021-04-28T09:02:35","ENERGY":{"TotalStartTime":"2021-04-05T19:48:08","Total":12.505,"Yesterday":0.902,"Today":0.007,"Period":0,"Power":1,"ApparentPower":9,"ReactivePower":9,"Factor":0.08,"Voltage":237,"Current":0.037}}
09:02:50 MQT: tele/%topic%/STATE = {"Time":"2021-04-28T09:02:50","Uptime":"0T00:03:57","UptimeSec":237,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":2,"SSId":"FritzBox7412","BSSId":"2C:3A:FD:17:AC:A4","Channel":6,"RSSI":92,"Signal":-54,"LinkCount":1,"Downtime":"0T00:00:06"}}
09:02:50 MQT: tele/%topic%/SENSOR = {"Time":"2021-04-28T09:02:50","ENERGY":{"TotalStartTime":"2021-04-05T19:48:08","Total":12.505,"Yesterday":0.902,"Today":0.007,"Period":0,"Power":1,"ApparentPower":9,"ReactivePower":9,"Factor":0.09,"Voltage":237,"Current":0.039}}

But I do not receive them:

 mosquitto_sub -h localhost -t tasmota_5382AA
^X
^Croot@OpenHAB:~#

I also tried mosquitto_sub -h localhost -t tasmota

You are subscribing to a topic that dosen’t exsist.

Try -t tele

Or #

You’re supposed to assign your own value here in Tasmota settings, usually a “name” for your device.

Bot does not change much

@rossko57 This brings me then

10:07:14 MQT: Attempting connection...
10:07:14 MQT: Connected
10:07:14 MQT: tele/tasmota_5382AA/LWT = Online (retained)
10:07:14 MQT: cmnd/tasmota_5382AA/POWER = 
10:07:14 MQT: tele/tasmota_5382AA/INFO1 = {"Module":"Gosund SP111 2","Version":"8.2.0(tasmota)","FallbackTopic":"cmnd/DVES_5382AA_fb/","GroupTopic":"cmnd/tasmotas/"}
10:07:14 MQT: tele/tasmota_5382AA/INFO2 = {"WebServerMode":"Admin","Hostname":"tasmota_5382AA-0682","IPAddress":"192.168.103.40"}
10:07:14 MQT: tele/tasmota_5382AA/INFO3 = {"RestartReason":"Software/System restart"}
10:07:14 MQT: stat/tasmota_5382AA/RESULT = {"POWER":"ON"}
10:07:14 MQT: stat/tasmota_5382AA/POWER = ON
10:07:18 MQT: tele/tasmota_5382AA/STATE = {"Time":"2021-04-28T10:07:18","Uptime":"0T00:00:12","UptimeSec":12,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":2,"SSId":"FritzBox7412","BSSId":"2C:3A:FD:17:AC:A4","Channel":6,"RSSI":92,"Signal":-54,"LinkCount":1,"Downtime":"0T00:00:06"}}

@denominator Thanks, this leads also not to any received messages:

 mosquitto_sub -h localhost -t tele

I also tried it on another server of my brother, where openhab displays the received info from another tasmota device (same model, but at his place). Also no messages shown by this way.

Can you see them using another client like mqtt explorer or mqttfx

In your other thread you “changed username and password”, I don’t know where, but this sounds like something you need to adjust in your tasmota too.