Moving mariadb to another server,

I have moved my mariadb installation to another (internal) server, leaving everything unchanged, but I changed IP in the UI with Server: jdbc:mariadb://
with the database openhab and with new user and password. Everything remained unchanged in the openhab Konfiguration including strategies. Openhab is on an other internal raspberry with 192.168.178.yyyy
After it did not work, I have uncommented also the jdbc file wit the new address, user and password.

But there is no insert of new data. What is wrong ? How can I see the error file (I am not so familiar with error logs). I suppose that there is something wrong in the jdbc:… or?

The mariadb allows the openhab server to login and to write data ?
Previously it most probably was localhost that was allowed now it is a remote IP address.

Check the content of the file openhab.log in /var/log/openhab ( as long as you use ‘standard’ linux installation ) for messages. If they are not already in change the log level for the binding.
Does the mariadb log file show any error message ?

Thank you very much:
To your question mariadb was also in the previous version on another server than open
I do not find a log file for mariadb the directory /var/log/mysql is empty
I was looking into the openhab log fiel and search for maraidab or jdbc - di not find it
Kind Regards

Check the configuration file of the database to make sure that logging is turned on resp. to have the right level of logging turned on.

Make sure the server allows incoming connections, so configure the fiewall to allow 3306 port trafic. ANd the MariaDB user also needs to allow database calls from external server. By default it allows only localhost connections.
Been there, done that :wink:

hello thank you
that I have done have had in the firewall ufw allow 3306. no result
Then I have temporarily deactivate the alle firewalls.nor result
I have defined the user openhab in mariadb with hosts %, so it should be accessed also from other ips
Regards Bernd

ok, there’s also a change needed in dthe MariaDB config, explained here: How to enable Remote access to your MariaDB/MySQL database on Ubuntu Bionic or MariaDB < v10.6 (

how can I do it.? I do not find a configuration file for mariadb, where logging or similar is written
And I wonder as on my other server (within my home network) everything was Ok. I think ist is more a jdbc issue in my connection, jdbc:mariadb://

I have done according to your link but nothing happens. And I wonder as in my former server I have not done such configuration with an a user at the openhab server. So I think it is an openhab problem with jdbc:mariadb://
I can always access the databases on this server with phpmyadmin from all my other servers

in mij jdbc config line to MariaDB, I have a Timezone added, something like: jdbc:mariadb://192.168.1.xx:3306/db-name?serverTimezone=Europe/Amsterdam

log:set TRACE org.openhab.persistence.jdbc should enable logging.

you may have to restart the OH service.
During startup of OH you should see that the driver is being loaded etc.

I have restarted everything open hab raspberry and maraud Server. And Surprise Surprise It works!
I do not know why

Thank you

Thank you.
I have reboot both open hab server andmaraidb server and Surprise It works!
May be that the change to was the reason, but do not know.
Will not change anything
Thank you very much

Just in case you changed the logging level for the persistence service. Make sure to reset it to its default value to make sure that the openhab.log file is kept small.