MQQT linked Switch, how to change ON and OFF message to 1 and 0

I have setup a MQQT broker and setup channels. I can see that it all works when using MQQT-Lens (Google Chome MQQT software). When my switch in Openhabian is set to ON it publish the message ON, on the right topic. The problem is that I want my ESP8266 with Arduino-code to listen to the same topic. All examples I have found expecting 1 and 0 instead of ON and OFF.

So how can I change what message the switch in Openhabian sends, or is it always ON and OFF, can not be changed?

Happy for any ideas!

Please have a look into map profiles

How have you configured the Thing? There’s two options on the Channel config to set the ON and OFF value.

Sorry, I blame my cold! I can not really understand how I missed that! Thanks!