Hello Community. I am new at OpenHab and since some days i had a little problem.

I can not reach my Pi over Putty if a MQTT client run in my Network.

On my Raspberry 3b+ I run the latest openhabian Image.
Over the config tool I installed the Mosquitto Broker. Fit first tryings to get some informations from my Client i implement the MQTT 2.4 binding.
The Client in my Network is a nodemcu programmed over arduino. I use the PubSubClient lib to integrate an MQTT functionality. This Client send every 2 seconds some enviromental informations to the broker (Temp and humidity). The nodemcu sends over port 1883.

The works great. I can see the Information on my paperUI. Other subscribers can Subscribe the topics and can Display the informations. So the Mosquitto is running fine and the binding do his Job.

But now the problem: if the System is running i can not access with putty to my Pi!

Putty finds the pi over the ip address and port 22.
But after insert login Information (User ans pw) there comes nothing… (tryed many times no wrong user or pw).

But if i unplug the nodemcu board i can normaly use putty to access the pi…

May somebody had an idea why it is so? Or somebody had the same problem and solved it? (May i did not find the topic in community )

Maybe you are sending data very quickly (although a message every two seconds is not that many…), so the CPU load on your Pi gets too high?

Unplug your NodeMCU, log in to your Pi, run the program “top”, leave the putty session running, and then start your NodeMCU again.

If you see the java process using up 100% of your CPU, something strange is going on :slight_smile:

By the way, how is your NodeMCU sending the data and how to you insert in into openHAB? Are you perhaps sending JSON and using a javascript to extract single data items? Or perhaps using the JSON mapper?

Please add your thing and item definitions here, and use screenshots if you have configured them via Paper UI.

Is it possible, that you give the NodeMCU the same IP as the Raspberry?


First I thought the same, but they have different IP-Adresses


I set the time between sending up to 1 Minute… Nothing Changed… Same problems

The java process using (max.) 2 % of CPU. The Mosquitto Broker use less then 0,3% (everytime the Broker get a Message)

The NodeMCU only sends messured values (like “1234” so there is no JSON Conversion). So no usage of JSON mapper. The Items shows the right values. So this Communication seems alright.

This problem only appers when I use an NodeMCU as Client. If I use an other Client (like “MQTTBox” for Windows) there are no problems to connect to the Pi with PuTTY.

Also I tried to Connect to an other Pi with PuTTY when the NodeMCU is active. There are no problems…

Until tomorrow I publish some pictures of my Code for the NodeMCU and my configs for the items.

If you have another computer available, try setting up an MQTT broker there, and configure your NodeMCU to use that. Or, use one of the publicly available brokers like the one from adafruit.

And then, start your NodeMCU and try to access your Pi.

I still have the impression that there is something strange with your IP configuration…