Mqtt binding 2.4 problems

Hello people,
I’m trying to setup the integrated MQTT broker and binding. But whatever i try, i always get the same error message telling me this:

I did not find any answers in the forums or else so therefor i’m reaching out to you guys.

I’m on a raspberry pi 3 using openhabian image. My simple stuff works without any problems (ikea tradfri, bluetooth, network binding and so on.

Did you setup the integrated broker? It’s an additional addon that needs to be installed.

yes i did, as a matter of fact i followed the MK-smarthouse tutorial as well as the BK-Hobby tutorial but none of both worked.

i also had big problems until i got it work (migrated from mqtt1 to mqtt2,4). as already mentioned i think it is important not only to install the mqtt binding, but even the “embedded mqtt broker” (to be found under misc). but then you must not have an external mqtt-client installed because they will not work parallel.
for me this was helpful:


sorry when i cannot help more, i´m a pure beginner and lucky because today got mqtt2.4 working finally :slight_smile:

1 Like

hold on, let me see if i actually do have mosquito installed. that would be a nooby thing wouldn’t it :slight_smile:

ok, so i guess it really was as simple as just deleting the “old” mosquito broker.

Did that yesterday evening and all of a sudden this afternoon i saw my embedded broker online.
Since then i even got one of my tasmotized sonoffs working via openHAB :joy: