MQTT Binding not running in OH2 PaperUI after install in openHABian

Hi, I have setup an openHABian system on a raspberry pi.
Everything appears to have installed as expected.
However, when I try to install the MQTT Binding from the Add-ons page in the PaperUI, the binding appears to install and a popup seems to confirm this.
But an MQTT Binding does not appear in the Inbox to or the Configurations menus.

I experienced this exact same scenario with a RaspBian system set up by hand.

I have enabled the option in ‘Legacy bindings Add-on Management’ section, but no difference.
I have configured the /etc/openhab2/services/mqtt.conf to have the settings I want to use.

I tried adding the Network Binding, like in the tutorial and that worked fine.

Can anyone see what I am missing out when adding the MQTT Binding?

This is normal, since the MQTT Binding is version 1.x.
Only 2.x Bindings are using the full feature set of OH2 (like Discovery in Paper UI, etc)
For example, the Network Binding is version 2.x and you can use the Inbox to add Things that have been discovered.

To use the MQTT Binding, you need to configure the /etc/openhab2/services/mqtt.cfg (not .conf) file and then define items that use it.

This will not have any effect in the case of MQTT since there is no 2.x version of the MQTT Binding. This options allows you to use a 1.x version Binding even if a 2.x version has been released.

Aha! I see.
thank you.