MQTT broker goes online only with localhost

Hi guys I need a tip, please

  • Platform information:
    • Hardware: Raspberry 4 4gb
    • OS: openhabian 32 bit latest version
    • Java Runtime Environment: zulu 11
    • openHAB version: 3.2.0
  • Issue of the topic: configuring MQTTbroker accept only localhost to go online
    it happened when I tried to install openhab in windows, even using mttq explorer it communicate with the PC when I setup localhost
    Same it is happening on raspberry pi I followed step by step all the instructions in the youtube video openHAB 3 Installation & Setup | MQTT Broker Setup | openHAB 3 First Setup | OPENHAB Tutorial - YouTube
    no way to have it online with the IP address of the device and all the external communication provides an error with connection refused
    the mosquito service is without authentication
    thanks for the help

You probably need to make a small change to your Mosquitto configuration file.

Further reading:

very strange!, the string: listener 1883
allow_anonymous true
was already there but when I restarted mosquitto it has accepted the IP
thanks buddy really appreciate

it worked, thank you very much!
just another quick question…
if I have to chek the same parameter for mosquitto in windows do you know where is the file?

No idea, but this may help:

in the c:\mosquitto\ directory on Windows.
Note: the Windows install lets you choose the directory.