MQTT client(s) cant see SONOFF, but MQTT server can!


Apologies if this is a simple question but I’ve been battling with this for a day or so and cant find the issue.

Using CloudMQTT it can see all the clients sonoff, MQTTlens and MQTTspy, all are associated to the same group sonoff (default).

Cloud MQTT can see and braodcast from all 3 apps/devices eg. MQTTlens and MQTTspy and SONOFF
MQTTlens and MQTTspy can see each others transmissions
MQTTlens and MQTTspy can see transmissiosn from CloudMQTT.

But neither MQTTlens and MQTTspy can see anything coming from the SONOFF, but CloudMQTT does.

Is there an obvious setting I’ve missed with the SONOFF config !

Any help or pointers would be greatly appreciated, many thanks in advance


sonoff config below

Sonoff Basic Module


Program version 5.3.0
Build Date & Time 2017-08-11T15:59:15
Core/SDK version 2_3_0/1.5.3(aec24ac9)
Uptime 1 Hours
Flash write count 147 at F9000
Boot count 65
Reset reason Power on
Friendly name 1 Sonoff

AP1 SSId (RSSI) xxxxxxx (84%)
Hostname sonoff-7478
IP address
Subnet mask
DNS server
MAC address 5C:CF:7F:B4:FD:36

MQTT Port xxxx
MQTT Client &
Fallback Topic DVES_B4FD36
MQTT User xxxxx
MQTT Topic sonoff
MQTT Group Topic sonoffs
MQTT Full Topic cmnd/sonoff/

Emulation None
mDNS Discovery Enabled
mDNS Advertise Webserver


For the benefit of anyone else that comes across a similar issue using MQTT, sonoff, tasmota.

While the MQTT group in tasmota FW is set to “sonoff”, when you look at it via an MQTT client using # (everything), you see pre and post bits added to the sonoff group ie. “stat/sonoff/POWER”

Hope this helps somone else