MQTT Configuration on Windows 10

MQTT Arrives in the Modern openHAB 2.x Architecture
David Graeff posted on Sunday, 16 December 2018

I am trying to duplicate the procedures that David speaks of in the online article noted above. These are the problems that I am encountering.

On a Windows 10 Machine. I have unzipped the stable 2.4 and placed it in a directory called OpenHab2. Configured zwave addon and now see all my devices in the Control section of the PaperUI. None (repeat NONE) of the addons in the article are available in the addons section of Paper UI on my machine. What do you think the problem would be?

You haven’t provided enough details I think to help and your title is misleading. You are not asking for help configuring MQTT, you are having a problem with your OH installation not showing bindings.

  1. How did you install the zwave binding?
  2. Where are you looking for the other bindings to install them?
  3. Please post screenshots of what you are seeing.


Thanks for the reply. I am sorry for not being precise enough. I have openhab2 working on two separate zwave networks. The zwave binding and all things on both networks are working great. When openhab 2.4 was announced I updated the one network. And started anew on the other network. As I had mentioned in my post, I read the article at the following link: The problem is that none of the addons that are mentioned in the article are available in the addons menu in paperui on either of my 2.4 installations. What I am trying to do is create some mqtt Things that can be updated from a raspberry pi in my garage. I thought that a good review of mqtt on openhab would give me the info I would need. I guess for now - How do I get the addons on my (or any installation) to include the addons that are mentioned in the above article?

Where are you looking for the add-ons?

Are you saying that there are no add-ons listed under bindings in PaperUI or you just can’t find the MQTT add-on?

That’s why I ask the questions and ask for the screenshots. All available bindings are listed under Add-ons -> Bindings. Search for MQTT and you should see one or two bindings (depending on whether you have show legacy bindings enabled). So if you have no add-ons listed or are missing some then there is something wrong with your OH. If not, then you might be looking in the wrong place.