MQTT Connection not working correctly

After reboot always:

2018-09-12 20:04:39.154 [ERROR] [] - Error starting broker connection

org.eclipse.paho.client.mqttv3.MqttException: Unable to connect to server

at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start( []

at org.eclipse.paho.client.mqttv3.internal.ClientComms$ []

at [?:?]

Caused by: Connection refused (Connection refused)

at Method) ~[?:?]

at ~[?:?]

at ~[?:?]

at ~[?:?]

at ~[?:?]

at ~[?:?]

at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start( ~[?:?]

... 2 more

So i’m starting it with “mosquitto -d”, is this correct?
Mosquitto is installed through openhabian-config

Yes, make your settings in mqtt-eventbus.cfg which should have been created after installing the binding.

“# Name of the broker as it is defined in the openhab.cfg. If this property is n$

Was already set (done a time ago)

You need to set that option to the same broker name as in your mqtt binding.

1 Like



or whatever topic you prefer.



I think i have to use “broker” instead of mosquitto,

Thats what he was telling you.

BTW why do you need the mqtt ACTION binding for turning on and off a switch? I dont use that binding and have nearly a dozen esp’s working with OH via mqtt.

I may be wrong but I think the question was ask to see if you had it installed, if so then, uninstall it. The action binding has (or had?) a history of interfering with the mqtt binding. So unless you need it, uninstall both mqtt bindings, clean your cache and reinstall the mqtt binding only.

1 Like

Thank you.
I think I’m going to reinstall Openhabian.
I’m writing if it helped.