MQTT not working with the sensor made with ESPeasy

Recently I made a wireless sensor using NodeMCU and DHT22 with the ESPeasy software and now I can not successfully connect it via mqtt. i’m guessing there could be a error in the broker or in the espeasy configuration. Have been working on this problem for quite long time and I still haven’t found the solution.

name of the device: sensor

setup the mqtt on esp


and made the sensor working



Generic MQTT Thing:

Number Temperature { channel=“mqtt:topic:58ab282c:temperature” }
Text item=Temperature label=“Temperature [%.1f °C]”

Thank you for the help in the advance

Use a string item for debugging first, it could be that ESPeasy is sending a JSON instead of a pure value.
Also observe the mqtt traffic with mqtt.fx or other applications.

Observed the traffic and I only got status, yesterday talked with another member of this forum and he got atleast 2 more messeges, so can I assume that the espeasy is not configured corretly?

In EspEasy click on devices then edit. You will need to use the Name (at the top) and the value name (at the bottom) in your mqtt topic. Also the topic will start with the Unit name found under Config tab, in your case that is sensor.
Example: /sensor/dht22/value_name_here

I believe in my case that the topic is set correctly:

Make sure you have installed JSONPATH transformation via PaperUI and add this to your mqtt thing config.

I’ve checked and JSONPath transformation 2.4x is installed and for the last part I don’t know where to look at to add this “JSONPATH:$.SI7021.Temperature”

See the last picture of your starting post, hit the “show more” and you will see a setting for “Incoming Value Transformation”.

1 Like

Yes, channel configuration, thanks @opus.

thank you, so I changed that and in the basicUI still haven’t recived any data.

The question is, did the device send something since you changed that setting?
I don’t know about your device, but such messages are either in steady timesteps or after a command was received. You should be able to monitor that with your mqtt viewer.

Here’s a good tool for mqtt that you may find useful.

So I contacted the ESPeasy authors and with their help I found out my mistake. Under the device menu I left the “Send to Controller” unchecked. Thank you for all the help.