MQTT problem with C2531 Controller


I’m having some problems when adding the C2531 controller from paper ui. After adding it, the thing is created but in a unknown state and the green light of the dongle goes off and some errors are registered in the log. I tried to upgrade to OH 2.5 following other post indications, but with the same result.
If I don’t perform any action from paper UI I can see information send it by sensors in the console. Could you help me?

My system information:
Raspberry PI 3 B+
OH 2.4
C2531 dongle (usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0018E1F76F-if00 -> …/…/ttyACM0)

Debug ouput:

6/21/2019, 6:46:07 PM - info: Logging to directory: ‘/opt/zigbee2mqtt/data/log/2019-06-21.18-46-07’
6/21/2019, 6:46:08 PM - debug: Using zigbee-shepherd with settings: ‘{“net”:{“panId”:6754,“extPanId”:[221,221,221,221,221,221,221,221],“channelList”:[11],“precfgkey”:“HIDDEN”},“dbPath”:"/opt/zigbee2mqtt/data/database.db",“coordBackupPath”:"/opt/zigbee2mqtt/data/coordinator_backup.json",“sp”:{“baudRate”:115200,“rtscts”:true}}’
6/21/2019, 6:46:09 PM - debug: Loaded state from file /opt/zigbee2mqtt/data/state.json
6/21/2019, 6:46:09 PM - debug: Saving state to file /opt/zigbee2mqtt/data/state.json
6/21/2019, 6:46:09 PM - info: Starting zigbee2mqtt version 1.4.0 (commit #927c4db)
6/21/2019, 6:46:09 PM - info: Starting zigbee-shepherd
6/21/2019, 6:46:18 PM - info: zigbee-shepherd started
6/21/2019, 6:46:18 PM - info: Coordinator firmware version: ‘undefined’
6/21/2019, 6:46:18 PM - debug: zigbee-shepherd info: {“enabled”:true,“net”:{“state”:“Coordinator”,“channel”:“11”,“panId”:6754,“extPanId”:[221,221,221,221,221,221,221,221],“ieeeAddr”:“0x00124b0018e1f76f”,“nwkAddr”:0},“firmware”:{“error”:“Unable to get firmware version”},“startTime”:1561135578,“joinTimeLeft”:0}
6/21/2019, 6:46:18 PM - info: Currently 0 devices are joined:
6/21/2019, 6:46:18 PM - warn: permit_join set to true in configuration.yaml.
6/21/2019, 6:46:18 PM - warn: Allowing new devices to join.
6/21/2019, 6:46:18 PM - warn: Set permit_join to false once you joined all devices.
6/21/2019, 6:46:18 PM - info: Zigbee: allowing new devices to join.
6/21/2019, 6:46:18 PM - info: Connecting to MQTT server at mqtt://localhost:1883
6/21/2019, 6:46:19 PM - info: zigbee-shepherd ready
6/21/2019, 6:46:19 PM - info: Connected to MQTT server
6/21/2019, 6:46:19 PM - info: MQTT publish: topic ‘zigbee2mqtt/bridge/state’, payload ‘online’
6/21/2019, 6:46:20 PM - debug: Mounted the cieApp (epId 11)
6/21/2019, 6:46:20 PM - info: MQTT publish: topic ‘zigbee2mqtt/bridge/config’, payload ‘{“version”:“1.4.0”,“commit”:“927c4db”,“log_level”:“debug”,“permit_join”:true}’
6/21/2019, 6:48:22 PM - error: Error: request timeout
at CcZnp. (/opt/zigbee2mqtt/node_modules/cc-znp/lib/ccznp.js:269:22)
at Object.onceWrapper (events.js:286:20)
at CcZnp.emit (events.js:198:13)
at Timeout. (/opt/zigbee2mqtt/node_modules/cc-znp/lib/ccznp.js:248:18)
at ontimeout (timers.js:436:11)
at tryOnTimeout (timers.js:300:5)
at listOnTimeout (timers.js:263:5)
at Timer.processTimers (timers.js:223:10)
6/21/2019, 6:48:52 PM - debug: Saving state to file /opt/zigbee2mqtt/data/state.json

Thanks in advance and sorry if my english is not good enough

It looks from the log like you are using MQTT - not the ZigBee binding -:

It might pay to update the title/tag so that the correct people read this?

That was the problem, I was trying to use at same time the port for MQTT and zigbee binding. Thank you for pointing me in the right direction :+1:

1 Like