MQTT Problems after 2.0 Upgrade

Hi There,

I’ve upgraded my 2.0 SNAPSHOT to 2.0 Stable and now I got some problem with mqtt-eventbus binding.

I’m transfering states from my Slave (OH2) to my Master (OH1), which worked great until yesterday.

The following commands are received by mosquitto_sub, but not recognized by my OH1 Master

/openHAB/slave/Contact_Windows_GF_Bath OFF
/openHAB/slave/Battery_Multisensor_GF_Bath 100
/openHAB/slave/Contact_Windows_GF_Bath ON

And the DEBUG log of my OH1 Master:

2017-04-22 10:04:27.717 [DEBUG] [.b.mqtt.internal.MqttActivator:34  ]- MQTT binding has been started.
2017-04-22 10:04:27.782 [DEBUG] [b.mqtt.internal.MqttItemConfig:72  ]- Loaded MQTT config for item 'Desired_Temperature_GF_Bath' : 0 subscribers, 1 publishers
2017-04-22 10:04:27.808 [DEBUG] [m.internal.MqttEventBusBinding:68  ]- MQTT: Activating event bus binding.
2017-04-22 10:04:27.863 [DEBUG] [m.internal.MqttEventBusBinding:345 ]- Initializing MQTT Event Bus Binding
2017-04-22 10:04:27.866 [DEBUG] [m.internal.MqttEventBusBinding:277 ]- Setting up Event Bus State Subscriber for topic openHAB/slave/+/state
2017-04-22 10:04:27.908 [DEBUG] [m.internal.MqttEventBusBinding:361 ]- MQTT Event Bus Binding initialization completed.
2017-04-22 10:05:58.438 [DEBUG] [.mqtt.internal.MqttItemBinding:44  ]- Publishing command 18.5 to /openHAB/slave/Desired_Temperature_GF_Bath

The configuration of the OH1 Master:


And of the OH2 Slave

Number Humidity_GF_DiningRoom  "Humidity: [%.1f %%]" (Humidity) { channel="zwave:device:d90ead21:node4:sensor_relhumidity", mqtt=">[mosquitto:/openHAB/slave/Humidity_GF_DiningRoom:s$

The other direction (Master to Slave) works great at the moment.

Are there any changes to the binding which could lead to my problems? Is there any change in the format the binding is publishing to MQTT?


Finaly I got it. The old version was setting the “state” path without configuring it.

# Change
# To