MQTT - Recieving messages from sensors but not able to publish from Openhab

Just got a RPI up and running with Openhab2, mosquitto and a MQTT-ethernet gateway.
Sensors are sending to the broker and I can read it in Openhab, but when I tried a relay from “mysensors” I am not able to send a MQTT-message to the sensor.
I can see Openhab recieving data from the reley when it changes status but I am not able to change it from Openhab.

For the record, I’m totaly new to this so please be gentle and I have been searching forums for hours with no luck…

Items file:

Switch Belysning1 "Belysning" <garagedoor> {mqtt=">[broker:mygateway1-out/3/1/1/0/2:command:ON:0)],>[broker:mygateway1-out/3/1/1/0/2:command:OFF:1]"}
String Belysning1 "state [%s]" <door> {mqtt="<[broker:mygateway1-out/3/1/1/0/2:state:default]"}


           Switch item=Belysning1
           Text item=Belysning1



I would pick the issue is you’ve got two duplicate items names. Maybe make the state one a different name…

Ah, it works!
I had alot of “test stuff” in the sitemap an items-file.
Got rid of that and changed “mygateway1-out” to “mygateway1-in”.
This solved it!