MQTT sending issues with IOTLink

Hi Guys,

I have installed a touchscreen in our house to adjust settings to the openhab system aswell as to view trends etc.

This screen goes into Image Screensaver after a given time to show pictures of the family. Ive installed IOTLink " " on this to do some simple commandings from MQTT. However i cant seem to figure out how to send the correct mqtt command (any button command to cancel the screensaver) from a switch in Openhab to IOTLink.

It seems like whatever i do i cant get it to work. I send the commands from mqttspy to iotlink correctly but i dont receive any from Openhab

Im receiving everything else in MQTT fine, but i just cant fingure out how to send the command correctly

Currently using MQTT1 Openhab 2.5

Thank you and regards

I wonder what those are.

I wonder what your best guess is at the moment.

mqttspy :


Switch DisplayOFF_ON {mqtt=">[mqtt:iotlink/workgroup/desktop-k4lievf/commands/send-keys:command:ON:'{F11}]' "}

At the moment ive verified that the command comes through with mqttspy taking the chrome into fullscreen with F11, Ive tried different methods but it does not seem to be sent from openhab.

Thank you and regards

I think the bracket is misplaced here?
command:ON:'{F11}'] "}

Good Catch but still no sucess :frowning:

no errors either but its not showing up in mqttspy, i might need to dive deeper with mqtt debug unless someone sees anything special.

Thanks anyway :slight_smile:

Check in your events.log that your Item is actually getting a command.

Check that your broker is named mqtt - compare with your other mqtt Item configs.

There isn’t very much to go wrong here.

For testing, try any command, *

If all else fails, try a String type Item

Managed to get it to work, it was a type error in the computer name, I and 1 looked really similar with that font :thinking:

Got it working with both String command and as a switch :slight_smile: thank you for all your help.

Best regards