MQTT Tasmota Analog signal A0

I’ve the following thing config

  Thing topic veluxRolloBad {
        Type number : watersensorKitchen  "watersensorKitchen" [ stateTopic="tele/veluxRolloBad/SENSOR" ]

and my item config

  Number watersensorKitchen_test "Watersensor" (gDG) {channel="mqtt:topic:mosquitto:veluxRolloBad:watersensorKitchen"} 

In the log I see

Incoming payload '{"Time":"2021-05-24T23:06:17","ANALOG":{"A0":3}}' not supported by type 'NumberValue'

Any help why this happens?
I want to read the A0 value (which is 3 in this case).

Because the channel is trying to stuff the whole MQTT payload into a Number Item, that’s what you asked it to do,

Simplest option is to use JSONPATH for state transformation in the channel settings, as used with many other Tasmota messages.

Thanks! Indeed. Problem solved by

Type number : watersensorKitchen  "watersensorKitchen" [ stateTopic="tele/veluxRolloBad/SENSOR", transformationPattern="JSONPATH:$.ANALOG.A0"]
1 Like

Hey, i got exactly the same problem, i tried it with jsonpath (its also in the addons) but no valure is showing on the sitemap :/?

If you had exactly the same problem, it would have exactly the same fix.
Maybe you could provide details of your actual problem - what have you set up, what messages do you see?