Multiple Zwave devices showing up in Inbox upon search - neither one works

Hi everybody,

I am fairly new to openHAB but have been setting up and configuring my system for a few days now with considerable success (as I would regard it). Reading up on past problems in the Community has helped me a great deal, but right now I seem to have stumbled upon a problem nobody else seems to have encountered.

I am currently trying to add two Devolo Metering Plugs (MT02646) to my Zwave network. Each time I put the Zwave binding and plug into inclusion mode I get multiple new nodes each showing the plug’s model and manufacturer. I have tried adding any or all of those new nodes as things but neither option seems to work. The new things are either marked as “OFFLINE - COMMUNICATION ERROR” after a few seconds or are shown as online but with the added remark “Node initialising: REQUEST_NIF” or “Node initialising: PING”. I have also tried including them within direct range of the controller (2m distance without any obstacles in between), with the same result. After numerous inclusions, exclusions and resets of the plugs I have no idea how to continue and make them work with openHAB. They used to work fine with a different gateway just a few days ago, therefore I am ruling out a hardware problem.

The same issue (multiple devices found) occurred during inclusion of a Qubino Flush 1 Relay a few days earlier. Two nodes were found, one of them never worked, the other eventually got initialized correctly and works fine since then.

In addition to the Zwave stick I have a Hue bridge V2 with associated devices which works fine. When including new devices here every device shows up exactly twice, under the same name. When one of them is added as a thing the other is automatically ignored. Regardless of which one is added the devices always work as expected. I don’t know whether those two observations might be connected.

I am running openHAB 2.4 stable via openHABian on a Raspberry Pi 3B+. Zwave controller is a UZB Stick by Z-Wave.Me. Zwave binding is the standard (?) one by Chris Jackson. All operations via Paper UI. The rest of the Zwave network consists of several Qubino Flush Shutters, -Relais and Fibaro Plugs. All devices are supported by openHAB according to the binding documentation.

What can I do to successfully include those plugs? Any help is appreciated!

Also, if this is the wrong category I am posting in, please let me know and feel free to move the topic.

Hi,

did you find a solution? I have a similar problem with an Aeotec Trisensor.
Everytime I reset the sensor and re-try to add it I get an additional entry in the device search.
Screenshot_OH_254|690x371

This is correct. If you reset the device and re-include it, then the controller will give it a new node number and it will be considered a new device. This will ultimately cause some issues with the nodes that now don’t exist (you may see references to “ghost nodes”).

You should avoid resetting the device - instead you should exclude it from the network so that it is cleanly removed and the controller can then remove it from its internal tables.

Hi Chris,

is there a solution to this without a hard reset of the z-wave controller?