Multisensor 6 motion light control

hi all,
i have a strange behavior of the multisensor 6. i use motion detection to turn on the strip light on the bathroom. so when movement is detected will turn on the light. the problem is that time to time even is no movement in the bathroom the sensor will turn on the light. to turn off the light i use expire1 binding so the light is turned off after 1 min but than again it goes on after 5 -10 min. the sensor is placed in bathroom and even the door is closed the sensor detects movement.
Switch OgindaBaie2 "Oglinda" (AllLight) {channel="zwave:device:0054f01b:node3:switch_binary2", expire="1m,command=OFF"}
Switch AlarmMotion "Motion alarm" {channel="zwave:device:0054f01b:node28:alarm_motion"}
rule "Motion sensor triggered"
Item AlarmMotion received update ON
does anyone know why this multisensor 6 (aeotec) motion detection fires when there is no movement? i suppose maybe the there are some parameters to be set in the sensor configuration.
the factory config is:
Motion Sensor reset timeout =240
Motion sensor sensitivity =5 maximum
Motion Sensor Triggered Command=send basic set cc
Timeout after wake up=15
Sleep State=asleep
my goals are:

  1. configure somehow this sensor to fire the light only when real movement is detected.
  2. to modify the rule because i have another light in this room so when the main light is on do nothing and if the main light is off to fire the rule.
    thanks all.

That sensor has a 5 step sensitivity value that defaults to most sensitive.
We have 4 different entries for this, depending on firmware. I believe you want to change configuration parameter 4, assuming this is a ZW100.

yes its a zw100 with firware 1.10.
parameter 4 is set to level 5 (maximum). it came like this from factory and i left it set to maximum because it doesnt turn on the light instantly, it needs 1 or 2 sec to detect movement and to send comand on to the light item and i thought that if i change the sensitivity to less than 5 ill have to dance in the bathroom to turn light on :slight_smile:

When there is motion, how fast does the sensor trigger? Perhaps set a rule & timer that only turns on the light if there are 2 or more consecutive movements detected?

it trigger after 1 or 2 sec. i need it to react instantly. go in bathroom and have light. this is what i would like to get.
i modified the rule to check the main light state before turning the led strip on but it doesnt work.

rule "Motion sensor triggered"
    Item AlarmMotion received update ON
	if (PlafonieraBaie.state == ON) {
            logInfo("led off - plafoniera on")
	else {
            logInfo("plafoniera off - aprinde led")

i got this error:
2020-04-09 14:41:02.580 [ERROR] [ntime.internal.engine.RuleEngineImpl] - Rule ‘Motion sensor triggered’: An error occurred during the script execution: index=1, size=1
any tip?

Check your logInfo.
Maybe this would work:

logInfo("led off", "plafoniera on")

Yes it works. That was it, thank you.
Now I have to figure how to set the zw100 sensitivity. After this new settings I noticed that the sensor have some periods in which it doesn’t work at all. Like you pass near it and it doesn’t detect anything, the green led that blink at movement is dead and also in the log nothing appears.
The distance between sensor and the gen5 usb stick is not more than 2 meters.
Thanks again.

What setting are you currently using?

Please see the bottom of the 1st post.

Could it be the reset timeout period that causes this?

I don’t know… maybe?
Anyone who have this type of sensor (zw100) can tell me what values are recommended? Please see the bottom of the 1st post to see my config. I didn’t modify anything, this is how the sensor came from factory.

Does it not work for 4 minuets then start working again? If so change the reset to a shorter time.

Recommended values will be bases on each persons needs so play with the setting until you have it working as expected.

Is there a standard time for a minuet? :face_with_raised_eyebrow:

1 Like

Please excuse my French. :rofl: Pun intended! :wink:

1 Like

You’ll have to wait a minute :rofl:

1 Like

Now it works every time you pass near it but even it is set to 5 at maximum sensitivity level it not fires the light when you open the bathroom door to go in or when you just enter the room. It needs 1 or 2 sec to see the green led and to do the job. I’ll try to decrease the reset period to see what’s going so.

Hi, I’m not an expert with openhab by any means but I do use this same sensor in our bathroom without any issue.

The main difference in the rule I use is that I do not use the received update method.
I use ‘Item changed to ON’ to trigger the light on and then have a ‘item changed to OFF’ to turn the light off. This happens either after the 4 minute cycle of the sensor or sometime later when there is no more movement, teenage son has long showers!

Thanks @paulf for answer. I have 2 sensors zw100 and one of them act strange on movement detection like I said above, even there’s no one around it turns the light on time to time. I tried to reduce the sensitivity but same result. I than switched the sensors, I took 2nd one and put it in bathroom and did the necessary oh settings. This one works ok I mean it turns the strip light only when detects movement in bathroom but I now come to the next problem: it turns the light on only after 2 sec after you enter the bathroom so you practically enter the room in dark and have to wait 2 sec to have light. This is annoying.
Both sensors have same firmware and same settings. I don’t know what to say, they are much more expensive than other sensors but still they don’t work properly as I was expecting.
Tell me please your sensors turn light on instantly? Or you have to wait a few seconds like me?

Pretty much instant for the most part. On occasions there is a delay but that happens with every device in the house at some point, more of an issue with running openhab on a Windows laptop than individual devices.

I did have to have the multisensor 6 replaced under warranty though. The original one stopped updating the luminous sensor, updating firmware made no difference.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.