My experience migrating from OH2.5 to OH 3.0

Hi All

Just thought I would list some of the issues I had when migrating from OH2.5 to OH3.0.

  1. Rules all errored - change import statements
    The cause of this was the use of eclipse.smarthome in my imports.
    These must be manually changed to the new openhab.core
//import org.eclipse.smarthome.model.script.ScriptServiceUtil
import org.openhab.core.model.script.ScriptServiceUtil
 Had half hoped that the upgrade would take care of this - but I guess would comp0licate things dramatically?
  1. Persistence did not work as expected using the "built-in RRD4j.
    I was using MapDB in my 2.5 setup for the basics. But after watching the Virtual Meetup and trying some of the new features I could not get this to work.
    Eventually turned out that the RRD4j add-on was not installed, so installed that - still not working
    Then changed the Default Persistence service to RRD4j which solved that problem.

  2. When setting up the Model, only locations which have a EQUIPMENT configured in them are displayed on the Overview\Location page. Even if there are working Points, the Card does not display unless there is Equipment.

  3. Could not find an easy way to Migrate existing items to the Model (or move them around in the model). Appears that have to be “Created” using the correct names etc in the model and only then do they “move” to the correct position in the Model.
    It would be really great to be able to EDIT an item and get it placed in the model
    I hope that this is not just something I missed?


An Item’s position in the model is defined based on Group membership. If you want to add a semantically tagged Switch Item to the Kitchen location, make that Switch Item a member of the Kitchen Group. It’s as simple as that. The same goes for Equipment. To add an Item as a Point/Property of an Equipment, add that Item as a member of the Equipment Group Item.

Thank you Rich. That was helpful.
Just to clarify though you also have to add the semantic tag, otherwise still does not show up in model.
On rereading your response I think you covered that… But just adding an existing ITEM to the correct Group does not populate it into the Model - you have to add the Sematic Tag as well.

Always appreciate your input.

Correct. A semantic tag is required for anything to be a part of the model. It is not expected or even suggested that all your Items and Group be semantically tagged so you will have some Items or Groups that are not a part of the model.