My Galaxy Note 4 doesn't register in my.openhab

I have an Android Phone Samsung Galaxy Note 4 with the latest official OpenHAB app installed.
The problem is that it does not show up in the “My Devices” list on the website, and as a result it doesn’t receive notifications sent via the “sendNotification” action (which is much more important for me).
Old devices are shown in the list.
The rest of integration works: I am able to view sitemaps and control items from the application via my.openhab remote connection.

I’ve already tried to reinstall the app, switch off WiFi (to ensure that it uses remote connection) and set up the connection from scratch. Again, I can control my OpenHAB instance from the application but I don’t see my Galaxy in the “My Devices” list, and I don’t receive any notifications on it.

Anyone can help me?

I have registered three different Android systems (phones, tablets) and all of them show up under “My Devices”.
The only thing I did in the App was
openHAB Remote URL= and choose the correct username and password.

What did you set up in openhab.cfg regarding security?

You should have this:

Adjusting openHAB security settings to work with my.openHAB

my.openHAB doesn’t pass authentication data through connection with your openHAB for security
reasons, so you need to disable local authentication, so that bundle will be able to make
requests to your openHAB. To do that you need to set security:option=EXTERNAL
and adjust security:netmask= to your local LAN IP subnet in your openhab.cfg.
After that my.openHAB bundle will be able to make requests while external requests will still
be authenticated against your local users.cfg. If you don’t expose your openHAB to outer
world you can set security:option to OFF to switch authentication
off completely.

Take a look >>>here<<<

Hi, thanks for advise!
Yes, I’ve set up security settings properly,otherwise, I assume, the whole my.openhab bundle would not work.

And of course I’ve done the following:

I’ll repeat one more time: I can control my OpenHAB instance from the application remotely via my.openhab.
The thing is that the device doesn’t register for some reason, and doesn’t receive notifications sent from my.openhab. Maybe there’s a bug somewhere in the app or in my.openhab…

[quote=“roher, post:3, topic:2424, full:true”]
Maybe there’s a bug somewhere in the app or in my.openhab…[/quote]

I don’t think so, notifications work fine on my system.

One last idea from my side:

Did you do a new install of openhab? And maybe forgot to copy the old uuid and secret into the new system?
Because then a new uuid and secret word is created and you have to adapt those into my.openhab …

Good luck.

No, it’s an old installation. And the application shows actual uuid and secret in “Menu” -> “Openhab Info”, the same as in my.openhab and in /opt/openhab/webapps/static

Anyone else can help me? Maybe Victor Belov?

Just to make sure that your issue is not a my.openhab or habdroid related problem I deleted my tablet 5 minutes ago for testing.
As soon as I started Habdroid on my tablet the device was re-registered under “My Devices” on

Sorry, your problem must be somewhere else and I have no clue whats going on.
Wait for the more experienced users …

Good luck.


There can be several possibilities why it doesn’t register but to understand the reason and possibly fix it I need to see the log of the app on your device. Will you be able to get a logcat from your device while starting openhab app on it? (the app must be killed and started from the scratch)? You can do it through usb cable with Android SDK or with one of apps on the market which are able to get logcat.


Thank you for your help Victor.
Here are the logs:

Interesting. I don’t see anything about GCM registration in your log. It should be either successful or failed, but there are no messages at all…
Can you please show me a screenshot of your settings of the app?

Yes, here it is:

Ahh, ok. So the problem is that you’ve set remote URL to instead of
Just change it to https and everything should work.
Also switch off ignore options for SSL - it will work without them, when you switch them on you are not protected from the man-in-the-middle attacks.

Yes, it works! Thank you for advice, Victor!

I’ve tested Notifications, and they work strange - they appear on my phone only after I switch off WiFi (to connect to my.openhab) and lauch the application. They don’t appear if OpenHAB app is connected to the instance locally.

Thank you. Because of your post I realised that I had missed the full stop (".") out between my and
Now it works on my mobile. Such a small omission, but key to operations!

I can’t register device on my iphone 7 with ios 10.1.1
I my am quite sure openhab app should be setting correct as I able to connect to openhab on 4G network,
I can’t receive any kind of notification from openhab by below method on rules

sendNotification("your@email.address", "Hello world!")
sendBroadcastNotification("Hello world!")
sendLogNotification("Hello world!")

I able to see three log have sent in web notification page at same time, web page “devices” shows No Devices You currently have no devices registered with openHAB Cloud, in apps, inside notifications also shows nothing.

any help?
does notification able to work with new iphone and iOS?