My logs broke today, not sure why

i’m not sure what happens but i came home today determined to fix a contact sensor that hasn’t been working for awhile. i removed it and brought it closer to the controller. i proceeded to turn on zwave debugging but i got an error:

Error executing command: Unrecognized configuration

this was around 9pm my time. i then discovered that logs just stopped working about 20 minutes before. the last message i see in openhab.log is from one of my rules (“closeOutsideDoors”). i tried restarting openhab (in docker) and even the server it runs on and no luck. it turns out a few “log:*” commands are failing and even a simple log:display

the filesystem is not full and the log folder is only about 8MB:

du -hs userdata/*
143M    userdata/cache
288K    userdata/config
276K    userdata/etc
2.5M    userdata/jsondb
4.0K    userdata/kar
7.9M    userdata/logs
129M    userdata/persistence
8.0K    userdata/secrets
52M     userdata/tmp
12K     userdata/zigbee
744K    userdata/zwave

the docker host has tons of free ram (48gb free)

docker stats on the container look like this:
6fc18f9453b2 openhab-openhab-1 1.57% 1.876GiB / 62.72GiB 2.99% 7.63MB / 21.8MB 568MB / 592MB 277

Please take a look at userdata/etc/ (userdata/ should be a docker volume)
look at the file org.ops4j.pax.logging.cfg, which should look like


which is another file in the same folder. If the link is correct, inspect the file log4j2.xml.
If the file is broken, here’s the link to the default file: openhab-distro/log4j2.xml at main · openhab/openhab-distro · GitHub

Interesting, that pax logging file is empty:

replaced it with a copy from a backup (matched your example) and it worked. i wonder what would edit this particular file. other files in the directory look intact and i was not at home at the log message stored in the logs and my scripts log quite frequently so i didn’t manually break it.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.